WordPress.org

Forums

User Language Switch
Front-end language only shows correctly when logged in (1 post)

  1. hashimnaushahi
    Member
    Posted 11 months ago #

    Hi there,

    Thank you for offering great support!

    I've got everything installed in English. To display the front-end in Dutch I've downloaded the .po and .mo files and placed them correctly. In the settings I've chosen English for the back-end and Dutch for the front-end.

    After testing it I noticed two things...

    1. The front-end only shows in Dutch when I'm logged in. But when I'm logged out it shows in English again.

    2. Somehow /en_US/ showed at the end of the URL of the homepage of my website. Leaving it or removing it doesn't effect the language when I'm logged out. But when I'm logged in, removing it makes the site show in Dutch and leaving it makes it show in English.

    When visiting my website http://hashimnaushahi.com it'll look everthing is already translated. However, my site runs on the Genesis Framework and I've edited all the texts in Genesis so that everything looks Dutch.

    What you will notice is that the date of the posts and comments is shown in English. And also the texts of the comments and the comments form are in English. All these texts are shown properly in Dutch when I'm logged in, but not when I'm logged out.

    I hope you know a way to solve this. I'm looking forward to your reply. Thank you in advance!

    Sincerely,

    Hashim

    https://wordpress.org/plugins/user-language-switch/

Reply

You must log in to post.

About this Plugin

  • User Language Switch
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic

  • RSS feed for this topic
  • Started 11 months ago by hashimnaushahi
  • This topic is not resolved
  • WordPress version: 3.9.1