Support » Plugin: WP Mail SMTP by WPForms » ‘From Name’ and ‘From Email’ do not match my settings

  • Resolved cag8f

    (@cag8f)


    Hello. I have your plugin installed and activated on both my live site (https://feedxl.com/) and my dev site (https://wordpress-dev.feedxl.com/). For my ‘Mailer’ I have specified Gmail. On my dev site, when I send a test message, the test email is delivered expected recipient email account. But the ‘From Name’ and ‘From Email’ are not what I have set in Settings–>WP Mail SMTP–>Settings–>Mail. Here are screenshots: https://imgur.com/a/7ZtJ0tz How can I troubleshoot and resolve this issue?

    To be clear, I am not trying to override any of the Gmail settings in terms of ‘From Name’ and ‘From Email.’ My issue is that your plugin settings indicate that the ‘From Name’ and ‘From Email’ will be certain values. But in the actual email that is sent, those values are different.

    There are no errors in the PHP error log.

    I should note that my live site does not suffer from this issue–only my dev site.

    Thanks.

    • This topic was modified 3 months ago by  cag8f.
Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Support Sanjeev Aryal

    (@sanzeeb3)

    Hi @cag8f,

    I apologize for any confusion here. ‘From Email’ will be the email address of the google account you authenticated. In this case, it seems you used chelsey@feedxl.com email address to authorize your Google account and the one in the settings (support@feedxl.com) does not matter. Also, please update the plugin to the latest version.

    I hope this helps!

    OK thanks for that. I’ll look into authenticating a different account. I have a separate, but related question. As you can see, when an email is delivered, the ‘From’ field is populated with just an email address, e.g. chelsey@feedxl.com How can I ensure the ‘From’ field is populated with a name and email address, e.g. FeedXL Support <chelsey@feedxl.com>? In Settings–>Mail–>From Name it indicates,

    >> Gmail doesn’t allow to override From Name. Emails will not have From Name defined at all.

    So I guess this means, if I use Google as a mailer, I cannot specify a name in the From field–only an email address. Am I understanding that correctly?

    Also, on my site, the Google Client ID and Client Secret are already populated with values. I see the instructions you linked which explain how to create such values. But, the plugin was originally installed and configured by a colleague of mine. She said she did not follow any of those instructions. She said, because she was already logged in to the G-Suite account in-question (chelsey@feedxl.com), the Client ID and Client Secret fields were automatically populated in the plugin. Does that sound accurate? If so, could I follow those same steps to obtain the Client ID and Client Secret attached to a different G-Suite account (wordpress@feedxl.com)?

    Sorry, but disregard my last message about Client ID/Client Secret autopopulating. I misunderstood what my colleague had explained to me.

    I have an update. I created a Gmail app, attached to wordpress@feedxl.com. When I add those credentials to my dev site–located on https://wordpress-dev.feedxl.com–I encounter an error. Namely, when I click ‘Allow plugin to send emails using your Google account’ it redirects me to an error 403 page, with the following text:

    403. That’s an error.
    
    Error: org_internal
    
    Application: FeedXL Website
    
    You can email the developer of this application at: wordpress@feedxl.com
    
    This client is restricted to users within its organization.
    
    Request Details
    That’s all we know.

    Additionally, at the top of the WordPress back-end page is the message:

    EMAIL DELIVERY ERROR: the plugin WP Mail SMTP v1.4.2 logged this error during the last time it tried to send an email:
    
    Mailer: Gmail
    {
    "error": {
    "errors": [
    {
    "domain": "global",
    "reason": "required",
    "message": "Login Required",
    "locationType": "header",
    "location": "Authorization"
    }
    ],
    "code": 401,
    "message": "Login Required"
    }
    }
    Consider running an email test after fixing it.

    Any ideas on why that is occurring and how I can resolve it? Keep in mind that my live site is on feedxl.com, and the email account I used to create the Gmail app was wordpress@feedxl.com. But in this exercise, I am trying to add credentials from that app to my *dev* site, which is on wordpress-dev.feedxl.com. Not sure if that’s related–just thought I’d throw that out there.

    Thanks.

    Plugin Support Sanjeev Aryal

    (@sanzeeb3)

    HI @cag8f,

    I apologize for the late response. Google seems to allow custom ‘From Name’ and it is available as of plugin version 1.5.0. However, Google seems to take ‘From Name’ from the ‘From Email’ for some DNS settings of your domain. The error:

    This client is restricted to users within its organization.

    As per the error message, you are authorizing the account that is non-member of the organization. The Google APP you created is restricted to users within it’s organization. If your organization is feedxl.com, make sure your email address is wordpress@feedxl.com and not subdomain like wordpress@dev.feedxl.com or vice-versa. Alternatively, you can remove this restriction. In case it helps, here’s the documentation.

    >> Alternatively, you can remove this restriction

    OK. In this case, creating an email address wordpress@wordpress-dev.feedxl.com is a bit challenging. So it is safe to remove the restriction, as you suggested?

    Plugin Support Sanjeev Aryal

    (@sanzeeb3)

    Hi @cag8f,

    I apologize for the late response. Yes, you can remove the restriction to share resources access to the outside member of the outside of the organization. You can choose to provide access to only specific domains. In your case, @wordpress-dev.feedxl.com. It seems you can also provide access to only certain Gsuite Customer ID. Please read the documentation about the domain restriction.

    I hope this helps!

    cag8f

    (@cag8f)

    Thanks for the info. But due to the difficulties in setting that up, and the delay in your reply, I had to move forward with a different solution (Postmark for WordPress).

    We can consider this resolved.

Viewing 9 replies - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.