From MT to WP? (7 posts)

  1. Fabien
    Posted 12 years ago #

    I am using Movable Type and as a lot of disappointed users I want to switch to WP. Is the conversion script usable with WP1.2 or do I have to switch to WP1 and then upgrade to WP1.2?
    Cheers, Fabien

  2. merialc
    Posted 12 years ago #

    I went straight to the latest nightly build and then used
    to import my mt stuff.
    Hope that helps

  3. OperaManiac
    Posted 12 years ago #

    yeah. the readme has the information on getting a MT blog into WP.

  4. paul
    Posted 12 years ago #

    Hmm, I had no trouble importing my MT stuff in the release version but in my CVS-based install, I get this:
    Fatal error: Allowed memory size of 8388608 bytes exhausted (tried to allocate 35 bytes) in /usr/local/www/data-dist/weblog/wp-admin/import-mt.php on line 66
    Fatal error: Allowed memory size of 8388608 bytes exhausted (tried to allocate 21 bytes) in Unknown on line 0

  5. annabloom
    Posted 12 years ago #

    @fabien: the conversion script comes with every release i think, and it works very well. i did the conversion about 5 weeks ago with the nighly build current at the time. i did create author and categories beforehand, although i'm not sure whether that is an requirement. the way you suggest (install ap1 and import, then upgrade) is probably _not_ necessary. to be sure, check the forum if there are problems with wp1.2-rc1 with regard to import-mt (i haven't seen a thread suggesting that; rc1 still has some issues but mt-import is not one of them).
    anyway, you'll be very pleased with the speed and convenience wp has to offer (furthermore i think it's safe to say that you won't read an announcement from the developers informing you that you have to pay for the features you got used to use or accept a crippled version)
    good luck

  6. paul
    Posted 12 years ago #

    yeah, it's interesting: I got it to work on one machine (my iBook) but not another (my FreeBSD server).
    I need to look into it more.

  7. paul
    Posted 12 years ago #

    OK, I just installed 1.2 and I am seeing the same problem.
    The error is flagged as being on this line:
    66 $datalines = file(MTEXPORT); // Read the file into an array
    but that seems to be a red herring. Are there any memory constraints I can adjust anywhere?
    Aha, it looks like php.ini might be what I am looking for. However, on both systems, the setting is identical (8 Mb).
    I changed it in FreeBSD to 128Mb and that seems to be working. I think I may change it back after this is complete. Curious why this wasn't necessary to twiddle in OS X?

Topic Closed

This topic has been closed to new replies.

About this Topic


No tags yet.