Contact Form 7
From field not outputting correctly (7 posts)

  1. jodzeee
    Posted 3 years ago #

    When mail is received, it's not coming from the e-mail address the sender input, but instead some odd e-mail address I assume is from the hosting account. Am I doing something wrong or is there anything I can do to fix this issue?


  2. bgoerzen88
    Posted 3 years ago #

    I'm having the same problem. Both Mail and Mail (2) do not output the correct information in the "From" field.

    To: myemail@gmail.com
    From: [FirstName] [LastName] <[Email]>

    Mail (2)
    To: [Email]
    From: Business <business@yahoo.com>

    Yes my shortcodes are spelled correctly. The "To" field in the Mail (2) works with the shortcode [Email]. it sends it to the correct person. But the [Email] shortcode does not work in the "From" field of the Mail section. It still shows I received an email from WordPress. I looked in the FAQ and used the formatting suggested, but it still didn't work.

    Also, the "From" field of the Mail (2) section doesn't show that it was sent from "Business <business@yahoo.com>" it still shows it was sent from WordPress.

  3. bgoerzen88
    Posted 3 years ago #

    Are there any known conflicts between other plugins?

  4. jodzeee
    Posted 3 years ago #

    I found this article somewhat helpful. I haven't solved my problems yet, but it offers some things to try or at least an explanation that it doesn't always work out of the box for everyone.


    I've got CF7 installed on another site and it works perfectly. I've never seen anything showing it being sent from WordPress (on either site) except when I tried not putting anything in the From field to see what happened.

    I actually have a bigger issue in that my client is not receiving the e-mails at their domain ... I'm going to start a new thread for that.

  5. bgoerzen88
    Posted 3 years ago #

    Thanks for the information, I'll give it some more troubleshooting and see what happens. It's just weird, I have the From fields set up the same way as they mention on the FAQ's section on their site... Anyway, thanks again for your help.

    Good luck to you and your client.

  6. bgoerzen88
    Posted 3 years ago #

    Just for a little more insight on this issue to other's who may see this thread.

    Instead of setting a shortcode for the email in the "From" field of the Mail section, I set it has an actual email address and it still came through as:
    WordPress <wordpress@businessdomain.com> via p3nlhg147.shr.prod.phx3.secureserver.net

    I feel like I'm missing something really simple?

  7. jodzeee
    Posted 3 years ago #

    I'm thinking/hoping that my issue is that their host doesn't allow the mail through because it's not being sent by someone on their domain. I've read a bunch about that and it didn't really sink in until I just read this article: http://wiki.dreamhost.com/Sender_Domain_Policy_and_Spoofing

    Their host is not dreamhost, but I imagine others have the same policy. So I've now tried it with a real email address from their domain in the from field and the user-input info as a reply to address in additional headers.

    I won't find out until tomorrow if it worked or not, but it might be worth a try for you.

    As I'm writing this, I'm in doubt it will solve my issue because their e-mail is hosted separately from their web hosting account so maybe I need to use the SMTP method mentioned at the bottom of the article.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Contact Form 7
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic