Support » Plugin: Cryptocurrency Checkout - Accept Bitcoin, Ethereum and Nimiq » From checkout redirected to /checkout/order-pay/

  • Resolved 3p1demicz

    (@3p1demicz)


    Hi,

    Great to finally have this official plugin. I am much looking forward to running it on our store.

    Is there a solution to not get redirected from checkout to checkout/order-pay/ when using the method “Pay with Nimiq”?

    I tried both “Behaviors” Popup and redirect, but both does the same.

    Thanks

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Nimiq

    (@nimiq)

    Hi!
    I have built it this way originally, so that the order exists in the system already when the payment is made, so that there can’t be a case where a payment is made, but no order registered (e.g. when the user closes the window after the payment, but before the popup closes itself).

    But you are not the first to notice this, so I will look into changing it to pay first, then order, or at least make it configurable.

    There is also a server-side redirect in the works, which would not require binding to a specific button, but there’s no ETA yet.

    I’ll let you know when I have an update for you.

    Thanks,
    Sören

    Plugin Author Nimiq

    (@nimiq)

    The new plugin version that will support BTC and ETH and removes the other payment options from the payment screen will be available at the end of this week.

    Plugin Author Nimiq

    (@nimiq)

    The new version v3 is now released and does not show other payment options on the payment page anymore. However, this separate payment page is required, because the order must be created in WooCommerce first before a user is allowed to pay.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘From checkout redirected to /checkout/order-pay/’ is closed to new replies.