Support » Installing WordPress » From 2.7.1 to 2.8 error.. can’t edit files now.

  • I just tried to run the install via the workdpress admin one-click method. It timed out after about 10 seconds.. no way it had time to update everything. I got some kind of error message I’m sure my hosting company set up saying “We’re sorry. Page is temporarily down. Please try again later.” I went back to my root domain. Everything still looks the same. I logged in to wp-admin again and now I go to my index.php page in the editor and instead of the contents of that page, it displays the following:

    <?phpif (!file_exists('phpThumb.config.php')) { if (file_exists('phpThumb.config.php.default')) { echo 'WARNING! "phpThumb.config.php.default" MUST be renamed to "phpThumb.config.php"'; } else { echo 'WARNING! "phpThumb.config.php" should exist but does not'; } exit;}header('Location: ./demo/');?>

    I then tried downloading 2.8 to my local machine and sending it up via ftp (except my themes, plugins and wp-config.php of course).

    I log in.. but still have the same error. Also.. in my Editor (wordpress Admin console), I now have extra pages listed that don’t exist in ftp! Examples are phpthumb.class.php, phpthumb.filters.php, phpthumb.gif.php, phpthumb.unsharp.php, etc..

    Any ideas?

Viewing 6 replies - 1 through 6 (of 6 total)
  • I am facing the same thing 🙁

    Being rather new with WordPress, I chose the automatic update to the 2.8 version and now this message appears when I type the url of my site :

    Fatal error: Cannot instantiate non-existent class: translations in /homez.154/karlosma/www/wp-includes/l10n.php on line 408

    Does someone has an idea about what to do?

    Does your site still work? That’s the odd thing about my issue.. my site still looks as it should.

    I’m going to check out the database tables.. I’ll let you know if I find anything.

    In your case though.. I would recommend downloading the 2.8 install and sending it up via http://ftp... except for themes folder, plugins folder and wp-config.php (in root wordpress directory).

    Nope, my site is not working anymore

    Ok, thanks for the advice.

    I will try out to install it via ftp and will let you know

    Hey Wolfdogg,

    Thank you so much!

    Everything is back to normal 🙂

    great help, I was really nervous to have lost the whole content (I did not save before to do the change).

    Have a great day!!!

    No prob. Glad to hear.

    I had the same issue and thanks to your advise I am also back online.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘From 2.7.1 to 2.8 error.. can’t edit files now.’ is closed to new replies.