Support » Plugins and Hacks » Friends Only » [Plugin: Friends Only] working with WP privacy settings (noindex,nofollow)

  • Resolved gorky5

    (@gorky5)


    I’ve been using this plugin to limit access to a photo gallery of my young son, so only selected friends and family members can access it. It generally works well, so thanks for creating it.

    When I set the website up I blocked search engines in Settings > Privacy, which added meta name=robots content=’noindex,nofollow’ to the pages within the site. However, Friends Only doesn’t seem to take any notice of this setting, meaning that the password page (effectively the new homepage) of my site is now listed by search engines.

    Is there any chance of an update to the plugin so it takes note of the privacy settings? I’d have thought that many people who want to restrict access would also like their site not to be listed by search engines. I could block spiders via htaccess but thought I should raise it here too.

    http://wordpress.org/extend/plugins/friends-only/

Viewing 15 replies - 1 through 15 (of 22 total)
  • Plugin Author Gabe

    (@gabrielwhite)


    Thanks for pointing this out!

    Just uploaded v0.4.4 to the repository with a fix for this, let me know how you go.

    Please rate the plugin in return. 🙂

    Cheers,

    Gabe

    Thanks Gabe. What a great response.

    Noindex,nofollow is now working fine. However, I’ve noticed that the doctype is missing from the page source of the password page (it was there before the latest update).

    It’s not really a big deal because the page is so simple and should render fine in most browsers, and in my case the site is only used by a handful of people so I’m not so worried. I thought it might be worth letting you know about though.

    Thanks again,

    Joe

    Hi,

    First i want to say that your plug-in is great to make a simple access for a page or a complete site, simple to use and it works perfectly.

    I have only 1 question, is it possible to put most than one email in the “Email notification”?
    I tried with a coma, between 2 email, but it seems it blocks all emails after.

    Ty by advance for your answer

    Best regards

    flyw

    Plugin Author Gabe

    (@gabrielwhite)


    @gorky5 – DOCTYPE issue fixed

    @flyw – you can now specify multiple emails for notification (separated by commas).

    Check out v0.4.5 uploaded to the repository just now.

    Gabe

    You are great !!!
    And now it’s writing, “friends only notification”
    very good !

    All works fine
    ty very much for your work

    best regards

    Flyw

    Great stuff. Thanks Gabe! I gave you a good rating on the plugin page 🙂

    Hi Gabe

    Another little thing.
    I see, there is a time limit for the connection, because after some minutes we are disconnected.
    For me, this time is too short.
    It is possible to adjust this time limit ?

    Thanks

    Best regards

    Flyw

    Plugin Author Gabe

    (@gabrielwhite)


    Flyw – the cookie is currently set to expire when the browser session is closed (i.e. when the user shuts down the web browser).

    I chose this because it’s more intuitively secure than a number of minutes (because there’s no ‘logout’ function, the user has no direct control over closing the session apart from closing the browser).

    If I used a count of minutes, the user might close the browser and then someone else opens it up and accesses the site,etc.

    Hi Gabe

    The only problem i meet is :
    for example, when you log in, you are on the homepage, and when you change on other page, the log in page appear again.
    What is the issue to resolve this problem.

    i just finished this site wich my client want a restricted access.
    http://www.providence-ams.fr
    password: friendonlytest@providence.fr

    ty for your advise

    Best regards

    flyw

    Plugin Author Gabe

    (@gabrielwhite)


    Just tried it, and saw the bug you talked about once, but then I tried again and it didn’t happen.

    I’ll keep it as something to look at later, but can you try with different browsers?

    I think it’s a cookie bug somewhere, but I’m not sure where.

    how you are fast !!!

    Then i just tried with, chrome, explorer, ffx and safari and i have always the same result.

    Plugin Author Gabe

    (@gabrielwhite)


    Hmm. Do you have any privacy settings or privacy software that might affect whether your browsers are storing / blocking cookies?

    Have you tried on another computer?

    1)No i don’t think so.
    2)I see this problem from the other visitors like you and others around 10 i think all the visitors has this problem.(with the connection’s information email).

    Plugin Author Gabe

    (@gabrielwhite)


    Hmm. Maybe it’s a bug with the way I’ve implemented cookies (though I haven’t heard anyone complain about this before), or maybe it’s another plugin or the theme you’re using interacting with Friends Only in a strange way.

    I’ll put it on my list of things to look into, but likely won’t get to it for a while.

    ok Gabe I Wait and see.
    Thank you for your interest

    best regards
    Flyw

    Accueil

Viewing 15 replies - 1 through 15 (of 22 total)
  • The topic ‘[Plugin: Friends Only] working with WP privacy settings (noindex,nofollow)’ is closed to new replies.