WordPress.org

Support

Support » Installation » Fresh install WP 2.3 ok -> upgrade to 2.3.1/2.3.2/2.3.3 result in blank page

Fresh install WP 2.3 ok -> upgrade to 2.3.1/2.3.2/2.3.3 result in blank page

  • On a Freebsd machine running apache 2.2.6 php 5.2.4 and my sql 4.1 (or 5 will check) I wanted to freshly install wp 2.3.3

    this resulted in blank screen on going to wp-admin/install.php

    I installed 2.0.11 without problem, upgraded to 2.1 series, no problem, 2.2 no problem, 2.3 is working fine now, but when I upgrade to either 2.3.1 or 2.3.2 / 2.3.3 it results in a blank screen on either wp-admin/install.php or wp-admin/upgrade.php and the server logs throw out a segmentation error 11

    Help !?!

    P.S.
    fresh meaning No plugins or themes, just plain WP zip file and thats it.

Viewing 7 replies - 1 through 7 (of 7 total)
  • Make sure you have enough memory allocated to PHP

    If your host doesn’t allow PHP error logging, then might look at commenting out line 163 in wp-db.php (see Trac ticket 5771)

    I’ll check and give that a go and report back, thanks

    im trying this with 2.3.3 now, however no joy

    i’ve changed my php.ini to have more memory available (32MB) the server has 2GB internal mem, so enough free for PHP/Apache.

    I’ve tried commenting out line 163 of wp-db.php however Im still getting blank pages on either the install or upgrade.php pages.

    Anymore suggestion that I can try ?

    ive been playing by replacing files on my working 2.3 install with files from the 2.3.3 install

    The blank screens start when I replace script-loader.php in wp-includes dir.
    is there a place where I can find a diff between 2.3 and 2.3.3 to debug more ?
    It seems im not allone in these blank screens on install

    EDIT:
    Ok, i’ve overwritten ALL files with v2.3.3 except script-loader.php and it still works, so that means that something has changed in script-loader.php that giving these blank pages/segmentation faults !

    Thanks for your help

    ok, i’ve looked around and this is the diff between 2.3 and 2.3.1/2.3.2/2.3.3

    http://trac.wordpress.org/ticket/5067

    Now i’m not a programmer, but why was this implemented?
    or better can we check to see if more people have this issue and how I/we can either fix our servers or take this change out to make it work in a more standard way again ?
    Thanks for your help

    Obviously the temp fix for now is to install 2.3.3 and get the script-loader.php from 2.3 and replace it
    Just mentioning this for other people have problems like this….

    I can add that the problem is still there with the new 2.5 release
    replacing the script-loader.php from the 2.3 install fixes the problem

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Fresh install WP 2.3 ok -> upgrade to 2.3.1/2.3.2/2.3.3 result in blank page’ is closed to new replies.
Skip to toolbar