Support » Networking WordPress » Fresh Install, subfolder multisite, infinite redirect loop sub-blog login

  • Resolved creativepublishing

    (@creativepublishing)


    Hello!

    I just installed a fresh install of WordPress and activated the network/multisite feature.

    I had no problem editing the .htaccess and wp-config.php file as I am reasonably competent in programming. The only deviation from the Network tutorial was that WordPress changed one htaccess rule, adding in my servers path.

    Creation of the first sub-blog went fine, but when trying to access the admin panel for the new blog I go into an infinite redirect loop. The blog itself loads fine, although with no formatting, I assume because I haven’t enabled any themes.

    The url is http://www.hostingserversdedicated.com/test/

    Any help would be greatly appreciated.

Viewing 11 replies - 46 through 56 (of 56 total)
  • Hey creativepublishing thanks it worked your solution, thank you…

    OK. I’ve read through this thread multiple times. Tried and retried the suggested solutions. I get nothing but redirect authorization loop. So, here are my details.

    WordPress is installed at: ~/htmlRoot/wordpress/
    Current blog is installed at: ~/htmlRoot/blog/

    In non-multisite mode, this setup works fine. However, when I follow the instructions (here) and then try to log in, I get this in the browser address bar:

    http://smittie.com/wordpress/wp-login.php?redirect_to=http%3A%2F%2Fsmittie.com%2Fwordpress%2Fwp-admin%2F&reauth=1

    My .htaccess file:

    RewriteEngine On
    RewriteBase /blog/
    RewriteRule ^index\.php$ - [L]
    
    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*) $2 [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
    RewriteRule . index.php [L]

    Obviously am I missing something. Can I buy a clue?

    — Smittie

    Just add.

    define('ADMIN_COOKIE_PATH', '/');
    define('COOKIE_DOMAIN', '');
    define('COOKIEPATH', '');
    define('SITECOOKIEPATH', '');

    to wp-config.php file.

    Perfect!! Thank you-! I had a bunch of other symptoms as well, and have been chasing down each one. This appears to have fixed them all.

    I used this boilerplate .htaccess code:

    I am using the same .htaccess code and was able to get it working briefly yesterday, however I had to fix a redirect issue in apache and when I did I can no longer get the subsites to work. I am able to create new subsites and the dashboard work correctly, however when you click on the login or register links a page can not be found message is issued.

    Here is the subsite http://teach.wpcc.edu/trying/

    Here is what I get when trying to logout/login from the subsite http://teach.wpcc.edu/trying/wp-login.php?action=logout&_wpnonce=f38c52190c

    Any ideas on how to fix this?

    @creativepublishing
    Thank you. Thank you. Thank you. Thank you. Thank you!

    @softmixtThank you! Thank you! Thank you!

    I will say that the following combination is really complicated:
    WordPress Multisite with subdomains using WAMP locally

    Custom edits for:

    • wp-config in WordPress
    • hosts file on Windows 7
    • httpd.conf in the WAMP Apache config
    • httpd-vhosts.conf in the WAMP Apache config
    • .htacess in the virtual host setup

    After all that… turns out your cookie code was the final piece I needed to get everything working the way I needed it to.

    Cheers!

    Recently I started to have redirect issues on our subfolder hosted site.

    http://www.landcruisingadventure.com

    So I used this boilerplate on the .htacces file in the subfolder:

    # BEGIN WordPress
    # END WordPress
    
    RewriteEngine On RewriteBase /
    RewriteRule ^index\.php$ - [L] # uploaded files
    RewriteRule ^([_0-9a-zA-Z-]+/)?files/(.+) wp-includes/ms-files.php?file=$2 [L] # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L] RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*) $2 [L] RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
    RewriteRule . index.php [L]

    From there everything on went smooth. Until I needed to sign in again, and I can’t acces my login page.

    http://www.landcruisingadventure.com/wp-login.php

    It sends my to:

    http://www.landcruisingadventure.com/wplca/wp-login.php

    but instead of showing the login page, it shows a 404 content?

    When I try to go to:

    http://www.landcruisingadventure.com/wp-admin

    it sends me to:

    http://www.landcruisingadventure.com/wplca/wp-login.php?redirect_to=http%3A%2F%2Fwww.landcruisingadventure.com%2Fwplca%2Fwp-admin%2F&reauth=1

    How do I get to my login page?

    Adventurous greetings,
    Coen

    @dains which lines did you carefully remove? I’ve tried this fix a few times and I still can’t get the dashboards for my subfolder sites to load.

    Hello I have a redirection loop problem with the page I am trying to make: http://www.trade-gate.net. Unfortuantely I don’t know much about coding. The problem started when I renamed some of the pages that are under my website. I renamed some pages several times I am afraid – not knowing that this might be a problem. Now I understand that all those records were kept somewhere in the memory of wordpress and authomatically wordpress keeps directing to each other.

    I don’t know how I will solve this. If I touch the htaccess file, I am afraid that everything will clash. I could not even understand whether the above fix that @creativepublishing proposed would fit me or not.

    I think there should be a simple solution to this because it can be encountered so easily while renaming pages.

    For example, one of the pages that have this problem is the following: http://www.trade-gate.net/eurostrong-televizyon-koltuklari/

    If you can advise a solution for me, I would greatly appreciate.

    Thank you.

    Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    🏳️‍🌈 Halfelf Rogue & Plugin Review Team Rep

    Guys, this post is RESOLVED.

    Make your own 🙂 It’s okay.

Viewing 11 replies - 46 through 56 (of 56 total)
  • The topic ‘Fresh Install, subfolder multisite, infinite redirect loop sub-blog login’ is closed to new replies.