[resolved] Fresh install: permalinks incorrect (6 posts)

  1. Funkphenomenon
    Posted 5 years ago #

    I downloaded a fresh install of 2.8.5 NL, installed in on the shared hosting where I already have 2 WP's running for a couple of years, but my fresh install doesn't have correct permalinks on the two default pages 'About' (in Dutch: 'Over') and 'Hello world!' ('Hallo wereld'):

    • Uppercase characters aren't replaced by lowercase characters
    • Spaces aren't replaced by dashes

    I have been using (and installing) WP for a couple of years now, but I haven't encountered this one before; permalinks on previous fresh installs always get rewritten to these-kind-of-permalinks (<- example).

    There seems to be no permalink problem when I create new pages or posts, as the permalink preview shows me it will be creating permalinks with lowercase with dashes.

    The server is a Linux machine with Apache and PHP 5 on it, with a default WP .htaccess in the root of my subdomain. Turning off all plugins and upgrading to 2.8.6 had no effect.

    Why do my 'About' and 'Hello world!' don't have the correct permalink?

  2. Nile Flores
    Posted 5 years ago #

    Try copying your htaccess from your other domains and loading it to this installation (if you have not already.)

  3. Funkphenomenon
    Posted 5 years ago #

    I first tried out the default .htaccess, then Andy Beard's 'ultimate .htaccess' (you'd think with that title things cannot go wrong ;), and now an edited version of my own .htaccess (edited as in: removed gzip rules and commented lines).

    Result: situation remains the same.

    Isn't there just something wrong with the installation procedure itself, in 2.8.5?

  4. Nile Flores
    Posted 5 years ago #

    That I would bring up as a question in the development part of the WordPress Support forums. I did not have a problem upgrading.

    For a basic install with the pretty permalinks structure and without the other htaccess options you can put in whether from Andy's tutorial, mine, or anyone else's...

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    # END WordPress

    If that is there... I would ask if you might email me - nile@wpaddict.net and make username, as well as your site URL that I can go and see what is going on.

  5. Funkphenomenon
    Posted 5 years ago #

    I also didn't have any problem upgrading; it's only with this fresh install on this new subdomain.

    Here's the temporary link, where you can see the following links on the homepage:

    It's probably better to try again with 2.8.6. I'll try again tonight or tomorrow, first deleting the database, removing all files, creating a new database, and then installing 2.8.6.

    If that doesn't work either, I might send you an email. Thanks!

  6. Funkphenomenon
    Posted 5 years ago #

    I re-installed the original (untranslated) 2.8.6 while keeping wp-content. That didn't work.

    I then removed the Dutch language files that were still present from the previous 2.8.5 verson, re-installed, and now it works.

    Looking at the Dutch .po file for 2.8.5 it contains a wrong entry in line 6843, where 'hello-world' [to produce the URL] was wrongly translated to 'Hallo wereld!' [which produces an incorrect URL]. Line 6867 contains the same error, but then with the URL for 'about'.

    So there was nothing wrong with the .htaccess after all.. Thanks anyway. I'll go tell the translator team about the two fixes.

Topic Closed

This topic has been closed to new replies.

About this Topic