WordPress.org

Forums

Admin Menu Editor
Fresh install gives saving error (2 posts)

  1. berendsen
    Member
    Posted 1 year ago #

    The plugin stopped working after migration. After reading some posts concerning this problem (old urls), I decided to uninstall the plugin, and install it again. Unfortunately, the plugin keeps showing this error message when I try to save the new settings:

    Failed to save the menu. Expected to receive 82206 bytes of menu data in $_POST['data'], but got nothing.

    How can this be solved?

    Kind regards,
    B

    https://wordpress.org/plugins/admin-menu-editor/

  2. Janis Elsts
    Member
    Plugin Author

    Posted 1 year ago #

    This error is usually caused by incorrect server configuration. It typically means that a security tool like ModSecurity, Bad Behaviour or Suhosin is blocking or filtering the menu data.

    For example, I've received similar reports from another user where it turned out the "save changes" request was modified by an excessively paranoid firewall that thought it was an SQL injection attempt because the menu data contained keywords like "update" and "set". Of course, in practice the request they were completely benign and the keywords were part of settings like "update_plugins" (a built-in capability string) and "Settings" (a menu title).

    I would recommend asking your hosting provider to check their security-related logs for recently blocked/filtered POST requests. They should be able to add an exception for this plugin.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Admin Menu Editor
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic

Tags

No tags yet.