Support » Plugin: Relevanssi - A Better Search » Fresh Install – Build Index Nothing Happens

  • Hello – I just installed your plugin, tweaked my settings, and click build index but nothing happens. I’ve left the page open and let it sit for an hour, but nothing changes. This is my staging site and I really want to use this plugin, but I can’t get it to work.
    Divi Theme
    Tried disabling all other plugins and reactiving.
    Tried deactiving Relevanssi and reinstalling – nothing changes.

    The page I need help with: [log in to see the link]

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author Mikko Saari

    (@msaari)

    It should react in seconds, at most in minutes. Please check the browser Javascript console (if you don’t know where that is, here are instructions). Are there any error messages there?

    Thanks for your quick response – this is the message I’m seeing…

    JQMIGRATE: Migrate is installed, version 1.4.1
    load-scripts.php?c=0&load[]=jquery-core,jquery-migrate,utils,jquery-ui-core,jquery-ui-widget,jquery-ui-mouse,jquery-ui-position,wp-pointer,underscore,jquery&load[]=-ui-sortable,suggest,jquery-ui-tabs,jquery-form&ver=4.9.8:3 [Violation] Added non-passive event listener to a scroll-blocking ‘touchstart’ event. Consider marking event handler as ‘passive’ to make the page more responsive. See https://www.chromestatus.com/feature/5745543795965952
    add @ load-scripts.php?c=0&load[]=jquery-core,jquery-migrate,utils,jquery-ui-core,jquery-ui-widget,jquery-ui-mouse,jquery-ui-position,wp-pointer,underscore,jquery&load[]=-ui-sortable,suggest,jquery-ui-tabs,jquery-form&ver=4.9.8:3
    a.event.add @ load-scripts.php?c=0&load[]=jquery-core,jquery-migrate,utils,jquery-ui-core,jquery-ui-widget,jquery-ui-mouse,jquery-ui-position,wp-pointer,underscore,jquery&load[]=-ui-sortable,suggest,jquery-ui-tabs,jquery-form&ver=4.9.8:9
    (anonymous) @ load-scripts.php?c=0&load[]=jquery-core,jquery-migrate,utils,jquery-ui-core,jquery-ui-widget,jquery-ui-mouse,jquery-ui-position,wp-pointer,underscore,jquery&load[]=-ui-sortable,suggest,jquery-ui-tabs,jquery-form&ver=4.9.8:3
    each @ load-scripts.php?c=0&load[]=jquery-core,jquery-migrate,utils,jquery-ui-core,jquery-ui-widget,jquery-ui-mouse,jquery-ui-position,wp-pointer,underscore,jquery&load[]=-ui-sortable,suggest,jquery-ui-tabs,jquery-form&ver=4.9.8:2
    each @ load-scripts.php?c=0&load[]=jquery-core,jquery-migrate,utils,jquery-ui-core,jquery-ui-widget,jquery-ui-mouse,jquery-ui-position,wp-pointer,underscore,jquery&load[]=-ui-sortable,suggest,jquery-ui-tabs,jquery-form&ver=4.9.8:2
    sa @ load-scripts.php?c=0&load[]=jquery-core,jquery-migrate,utils,jquery-ui-core,jquery-ui-widget,jquery-ui-mouse,jquery-ui-position,wp-pointer,underscore,jquery&load[]=-ui-sortable,suggest,jquery-ui-tabs,jquery-form&ver=4.9.8:3
    on @ load-scripts.php?c=0&load[]=jquery-core,jquery-migrate,utils,jquery-ui-core,jquery-ui-widget,jquery-ui-mouse,jquery-ui-position,wp-pointer,underscore,jquery&load[]=-ui-sortable,suggest,jquery-ui-tabs,jquery-form&ver=4.9.8:3
    initialize @ admin-bar-v2.js?ver=6.6-201841:15
    e.View @ load-scripts.php?c=0&load[]=hoverIntent,common,admin-bar,jquery-ui-resizable,jquery-ui-draggable,jquery-ui-button,jquery-ui-dialog,svg-painter,jquery-ui-dro&load[]=ppable,heartbeat,wp-auth-check,backbone&ver=4.9.8:302
    n @ load-scripts.php?c=0&load[]=hoverIntent,common,admin-bar,jquery-ui-resizable,jquery-ui-draggable,jquery-ui-button,jquery-ui-dialog,svg-painter,jquery-ui-dro&load[]=ppable,heartbeat,wp-auth-check,backbone&ver=4.9.8:302
    (anonymous) @ admin-bar-v2.js?ver=6.6-201841:70
    i @ load-scripts.php?c=0&load[]=jquery-core,jquery-migrate,utils,jquery-ui-core,jquery-ui-widget,jquery-ui-mouse,jquery-ui-position,wp-pointer,underscore,jquery&load[]=-ui-sortable,suggest,jquery-ui-tabs,jquery-form&ver=4.9.8:2
    fireWith @ load-scripts.php?c=0&load[]=jquery-core,jquery-migrate,utils,jquery-ui-core,jquery-ui-widget,jquery-ui-mouse,jquery-ui-position,wp-pointer,underscore,jquery&load[]=-ui-sortable,suggest,jquery-ui-tabs,jquery-form&ver=4.9.8:2
    ready @ load-scripts.php?c=0&load[]=jquery-core,jquery-migrate,utils,jquery-ui-core,jquery-ui-widget,jquery-ui-mouse,jquery-ui-position,wp-pointer,underscore,jquery&load[]=-ui-sortable,suggest,jquery-ui-tabs,jquery-form&ver=4.9.8:2
    K @ load-scripts.php?c=0&load[]=jquery-core,jquery-migrate,utils,jquery-ui-core,jquery-ui-widget,jquery-ui-mouse,jquery-ui-position,wp-pointer,underscore,jquery&load[]=-ui-sortable,suggest,jquery-ui-tabs,jquery-form&ver=4.9.8:2
    2build.min.js?8f9075ba3c81f81da4a4:85 [Violation] ‘message’ handler took 740ms
    [Violation] Forced reflow while executing JavaScript took 711ms
    [Violation] Forced reflow while executing JavaScript took 52ms

    Plugin Author Mikko Saari

    (@msaari)

    No (Relevanssi-related) errors there. When you click the “Build index” button, what exactly happens? Does the indexing status bar and message box appear? If it does, does the box stay empty, or is something printed in it?

    Divi works with Relevanssi, so that should not be an issue.

    When I click the button – nothing happens at all. The button gets a blue shadow showing that I’ve clicked it, but the screen doesn’t change. There’s no loading wheel in the browser tab or anything. It’s like a dead button. I tried to use firefox browser this morning too to see if it was a browser issue. Nothing happens at all. Time doesn’t change.

    Unable to display content. Adobe Flash is required.

    I did a screencast to show you what I’m seeing. When I roll my mouse over the different submenu links you can see the bottom bar showing an action will take place. When I roll over the build the index button there’s no action and when I click it nothing happens.

    screencast.com/t/jLTrCiVy

    Plugin Author Mikko Saari

    (@msaari)

    Sorry, watching the screencast requires Flash, which I don’t have, but if the button does absolutely nothing, that would suggest a wider problem with Javascript on your site.

    What happens if you go to the Relevanssi settings page, open then indexing thab, then open the Javascript console and enter this command to it:

    jQuery("#build_index").click();

    This simulates a click on the indexing button, and should trigger the indexing. If it doesn’t, hopefully there’s an error message.

    I’m getting this error code
    Uncaught SyntaxError: Unexpected token &

    JQMIGRATE: Migrate is installed, version 1.4.1
    jQuery("#build_index").click();
    VM641:1 Uncaught SyntaxError: Unexpected token &

    Plugin Author Mikko Saari

    (@msaari)

    Well, that’s something I haven’t seen before, and I have no idea what could be causing this. Unfortunately there’s nothing I can do about this, at least not without looking under the hood to see what’s going wrong. Something in the way your site is set up is not compatible with how Relevanssi expects things to work.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Fresh Install – Build Index Nothing Happens’ is closed to new replies.