Installed 2.9.2, Admin Panel Javascript Menu's and other functions not working. (13 posts)

  1. eligeske
    Posted 5 years ago #

    I just downloaded and installed 2.9.2 on my machine to start development and when I logged in to the admin panel none of the menu's and javascript are working.

    I open my other older version on the same machine and they work fine.

    Anyone have any clues as to what is causing this? It cannot be that big of a fix.


  2. esmi
    Forum Moderator
    Posted 5 years ago #

    Try re-uploading all files and folders - except wp-content - from a fresh download of WordPress.

  3. eligeske
    Posted 5 years ago #

    Already did that. :(

    This is a total fresh install of 2.9.2.

    Steps taken:

    1. Deleted all files from directory
    2. Redownloaded the zip to ensure no files were corrupted upon download or unzipping.
    3. Placed in clean directory, manually entered the database settings into the config file.
    4. Logged in.
    5. Same error. No javascript is working on the admin page.

    NOTE: this is a base install, nothing has been added, no plugins, no themes. Nothing.

    NOTE 2: All my other WP previous to this version has worked fine.

    Server Settings:
    Win XP Pro
    WAMP W/ PHP 5.3

  4. eligeske
    Posted 5 years ago #

    My FireBug catches this error upon admin panel load.

    convertEntities is not defined

    Line 32

  5. eligeske
    Posted 5 years ago #

    Ok.. So I lied.

    My other older WP installs admin panels are not working either.

    So, just to be clear.

    All my wordpress admin panels on my local environment are not working.


    What could be causing this?

  6. khena25
    Posted 5 years ago #

    Actually, the same thing is happening to me....

  7. esmi
    Forum Moderator
    Posted 5 years ago #

    @khena25: Don't highjack another poster's thread. Post a new topic.

  8. esmi
    Forum Moderator
    Posted 5 years ago #

    @eligeske: If this is across multiple installs and the most recent install uses the default theme and no plugins, I'd guess that the issue is within your local server.

  9. eligeske
    Posted 5 years ago #

    any ideas?

  10. eligeske
    Posted 5 years ago #

    I just found that my php_exif.dll was not loaded. But after loading it the menu's still do not work.


    Still combing through the server to find anything that might stick out.

    Any helpful advice would be appreciated!

  11. eligeske
    Posted 5 years ago #

    Upon wp-admin login, the menu's do not slide down as normal. When I click it, the page re-loads. So it appears that the javascript is not working in the admin panel at all.

    Does anyone know what the dependencies are for the
    ajax & javascript functions
    in the wordpress admin panel are?

  12. Mvd
    Posted 5 years ago #

    I just want to say that I have the same problem, on my other 2.9.2 installation it works fine though. In ff it works ok so it's mainly that IE has problems with it, but in FF some of my plugins (javascript) don't work.

  13. the.gecko
    Posted 5 years ago #

    I had the same problem and solved it. I compared my unzipped wordpress-2.9.2.zip file with an older working version (that was moved from a previous host's server) and the 2.9.2 version was missing most if not all the JavaScript files (.js) in the wp-includes\js folder. However, when I browsed the contents of the zip file, I could see them all in there!

    All that I can figure is that the built-in zip extract program that I initially used on Windows Server 2003 is restricted or partially locked down somehow. I then installed WinRar, unzipped the 2.9.2 version with it, copied all WordPress files over (except the wp-content folder and its contents) the existing files on the web server and success!

    Check your wp-includes\js folder to see if it has .js files in there.

Topic Closed

This topic has been closed to new replies.

About this Topic