Support » Fixing WordPress » FreeBSD 6.2, WordPress hangs in browser.

  • Resolved thesh0ck



    I am having a problem with FreeBSD6.2 and wordpress. I am using the same version of mysql, apache and php as on a freebsd 4.8 box but when I try to access parts of wordpress that redirect (no matter what browser I use) it just kind of hangs forever(says loading but nothing ever loads). The access log shows a single line with a redirect such as:

    xx.xx.xx.xx – – [01/Feb/2008:13:22:08 -0500] “GET /wp-admin/plugins.php?action=deactivate&plugin=akismet/akismet.php&_wpnonce=b4338ce3c5 HTTP/1.1” 302 5 “” “Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 6.0; SLCC1; .NET CLR 2.0.50727; .NET CLR 3.0.04506; InfoPath.2)”

    This suggests to me that the redirect is being sent to the browser but nothing happpens. No looping, no white page, nothing.

    As I said it only happens on FreeBSD 6.2. I have the very same site using the same database server on a freebsd 4.8 machine and it works fine. Also if I try it locally on the (6.2) server itself using command line lynx it works as well. It gets to the point in all browsers I’ve tried after a few attempts, the browser must be completely closed and reopened to even get back to the main blog page.

    I cant imagine that this is a browser issue as the same thing happens in firefox, safari, ie6 and ie7, in multiple sites and computers. Go to this page and see for yourself. If you can manage to login try clicking plugins and try activating or deactivating one.

    user admin
    pass 56e402

    Any help anyone can think of would be great.

    Things I have tried:

    Checked all logs, no errors or signs of looping anywhere(the php process is no longer running as well)
    Tried 6 different versions of php ranging from 4.3.9 to 5.1.2
    Tried 3 different versions of apache in the 1.3.x branch.
    Tried every browser I can think of.
    Searched google for possible solutions but because its so difficult to explain and there are so many similar but not related problems I couldnt find anything.

    Please let me know if anyone else has ever had this problem. I have a customer I need to move from a FreeBSD 4.8 machine to a FreeBSD 6.2 machine and keeping 4.8 is not an option.

    Thank you.


  • The topic ‘FreeBSD 6.2, WordPress hangs in browser.’ is closed to new replies.