Support » Plugin: WooCommerce Advanced Free Shipping » Free Shipping being applied to every order

  • Resolved brentst

    (@brentst)


    Hi,

    AFS is currently being applied to every order.

    You can see in the screen shot here https://prnt.sc/gqwlpf that i have a number of conditions that must be met to apply the free shipping yet a wholesale customer is getting the free retail shipping and retail customers that are under the minimum order are getting free shipping.

    Any help you can offer is greatly appreciated.

    Thanks,

    Brent

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author Jeroen Sormani

    (@sormano)

    Hi Brent,

    The only thing off I can see on the screenshot is the ‘$50’ value, a dollar sign is not needed, and may give unexpected results.

    Are there any other condition groups in that AFS rate? Do you have other AFS rates setup alongside that one?
    Maybe in the WC Zones?

    Make sure to use the shipping debug mode when you test for accurate shipping results 😉 http://jeroensormani.com/shipping-debug-mode

    Let me know!
    Jeroen

    Hi Jeroen,

    You are correct.Oncd i removed the “$” most of the free shipping conidtions worked.

    I have three different types of free shipping set up.

    Customer in Canada for over $5. This works

    Customer in USA for over $76. this works.

    Wholesale_customer for the provinces of (referred to as States in the plugin) BC, Alberta, and Saskatchewan over $500. This does not work

    Originally I had one of the conditions set up equal to user role wholesale_customer and it did not work. I have deleted that condition and have re-stated it as not equal to customer. Still not working.

    Any advice?

    Thanks,

    Brent

    Plugin Author Jeroen Sormani

    (@sormano)

    Hi Brent,

    Can you post screenshots of what you’ve got setup and isn’t working?

    Thanks,
    Jeroen

    Hi Jeroen,

    here it is

    https://imgur.com/Creu03C

    thanks,

    Brent

    Plugin Author Jeroen Sormani

    (@sormano)

    Hi Brent,

    Hi,

    Thank you for the screenshots.

    You’ve got multiple state conditions setup. This isn’t possible as you’re basically telling the system that the customer should be in multiple states at the same time, which isn’t possible.

    Instead you’d want to separate each state to its own condition group, with the other conditions included too.

    Cheers,
    Jeroen Sormani

    that worked great!! thanks very much for your help 🙂

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.