Support » Fixing WordPress » Free has disabled communication with external servers

  • Hi,

    I’m using the Wp-QuickLaTeX plugin, but it cannot connect to QuickLaTeX server because my hoster (free.fr) has disabled any kinds of communication with external servers.

    *** QuickLaTeX cannot compile formula:
    f(x)
    
    *** Error message:
    Cannot connect to QuickLaTeX server: Failed to connect to 93.171.209.4: Unknown error 101
    Please make sure your server/PHP settings allow HTTP requests to external resources ("allow_url_fopen", etc.)
    These links might help in finding solution:
    http://wordpress.org/extend/plugins/core-control/
    http://wordpress.org/support/topic/an-unexpected-http-error-occurred-during-the-api-request-on-wordpress-3?replies=37

    So after having installed core-control, I’ve consulted the last link in error message for resolution to change hosting provider, but I didn’t succeed in 🙁

    This is the result when I test the external HTTP access :

    cURL => “An Error has occured: Failed to connect to 203.98.84.95: Unknown error 101”

    PHP Streams => “Whilst an error was not returned, The server returned an unexpected result: , HTTP result: 0”

    PHP fsockopen() => “An Error has occured: 101: Network is unreachable”

    WP_HTTP_BLOCK_EXTERNAL Undefined
    WP_ACCESSIBLE_HOSTS Undefined
    WP_PROXY_HOST Undefined
    WP_PROXY_PORT Undefined
    WP_PROXY_USERNAME Undefined
    WP_PROXY_PASSWORD Undefined
    WP_PROXY_BYPASS_HOSTS Undefined

    http_request_timeout 5 5
    http_request_redirection_count 5 5
    http_request_version ‘1.0’ ‘1.0’
    http_headers_useragent ‘WordPress/3.5.1; http://***.free.fr‘ ‘WordPress/3.5.1; http://***.free.fr
    block_local_requests false false
    use_fsockopen_transport true true
    use_streams_transport true true
    use_curl_transport true true
    https_local_ssl_verify true true
    https_ssl_verify true true

Viewing 4 replies - 1 through 4 (of 4 total)
Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Free has disabled communication with external servers’ is closed to new replies.