WordPress.org

Support

Support » Plugins and Hacks » IProperty Real Estate Agent » [Resolved] Fractional baths not agreeing to 'no' setting!

[Resolved] Fractional baths not agreeing to 'no' setting!

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author thinkeryllc

    @thinkeryllc

    Hi – setting the fractional baths to ‘no’ will prevent the fractions from showing in the baths select drop down, but the value is still stored with a decimal point in the db.

    To fix the front end display if you have fractional baths disabled, you can edit your ‘iproperty/views/_compact_property.php’ file and find:

    <?php echo esc_html( $value ); ?>

    and change it to:

    <?php echo ($name == 'baths' && !iproperty_option( 'fractional_baths' )) ? round($value) : esc_html( $value ); ?>

    Let us know any questions. Thanks.

    Thank you – that worked perfectly on the general listing page… however… this doesn’t fix the fraction on the single property page 🙁 Where do I do this please?

    Thank you
    Carol

    Plugin Author thinkeryllc

    @thinkeryllc

    Ok, glad it worked. For the details view, open your ‘iproperty/views/single_property.php’ and ‘iproperty/views/single_property/main_tabs/_details.php’ files and find:

    <?php echo ( $value ); ?>

    change it to:

    <?php echo ($name == 'baths' && !iproperty_option( 'fractional_baths' )) ? round($value) : ( $value ); ?>

    Let us know questions. Thanks!

    Hmmm that hasn’t worked 🙁

    Forget that… it has worked… didn’t do it in both files… so now have and that’s perfect! Thank you so much 🙂

    Plugin Author thinkeryllc

    @thinkeryllc

    You’re welcome! Please don’t forget rate the product when you are satisfied!

    Same changes required in the file:

    /wp-content/plugins/intellectual-property-basic/views/single_property.php

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘[Resolved] Fractional baths not agreeing to 'no' setting!’ is closed to new replies.
Skip to toolbar