Support » Plugin: Social Media Feather | social media sharing » Found what looks to be a bug in WP3.6

  • Resolved Geansai

    (@geansai)


    Hi,
    Just installed the plugin into WP 3.6 and found a bug after install.

    After the plugin is installed and you go to a page or post to set the featured image the media pop window does not list / show any of the media which has been uploaded to the site, so you can not attach a featured image to the post or page.

    After looking into the issue I have found, this error notice:

    Notice: Undefined index: wp-page-slug in /var/www/unitedhouserepos/wp-content/plugins/social-media-feather/synved-option/synved-option-page.php on line 31

    So after changing lines 31 in synved-option-page.php to this:
    if (isset($synved_option_list[$id][‘pages’][$name])) {
    if(isset($synved_option_list[$id][‘pages’][$name][‘wp-page-slug’])):
    return $synved_option_list[$id][‘pages’][$name][‘wp-page-slug’];
    else:
    return null;
    endif;
    }

    from this:

    if (isset($synved_option_list[$id][‘pages’][$name])) {
    return $synved_option_list[$id][‘pages’][$name][‘wp-page-slug’];
    }

    All looks to now be working as it should, hope this is a help to someone! G

    http://wordpress.org/plugins/social-media-feather/

Viewing 1 replies (of 1 total)
  • Yes this is something I’m aware of and will be fixed in the next version (to be released this weekend).

    You will only have this issue if you have PHP notices enabled which isn’t common among hosting services.

Viewing 1 replies (of 1 total)
  • The topic ‘Found what looks to be a bug in WP3.6’ is closed to new replies.