WordPress.org

Support

Support » Plugins and Hacks » Found glitch. original image not written to server if size matches the default

Found glitch. original image not written to server if size matches the default

  • Dear Peter

    Found a glitch.

    Steps to reproduce:

    I made a minor tweak to the code – where the hardcoded size was 80 pixels. I changed it to 140. I believe the same problem should exist even if this tweak is not made, except at 80 pixels instead of 140.

    Everything was working fine. The plugin has always been creating two files on the server: one with the original file name, and another with “avatar” appended onto the file name.

    Then I happened to try to upload an avatar of this size: 140 x140. Exactly the default size.

    When I did, the “original” file never got written, but the one with “avatar” appended onto the name did get written.

    I then tried to upload an avatar that was slightly larger (240×240) and that time both files got written.

    Note: When using a file of size 140×140, and with the original file not getting written, it makes the “cropping” feature of the dialogue box display “broken link” X’s because it cannot find the “original” file on the server.

    http://wordpress.org/extend/plugins/add-local-avatar/

Viewing 1 replies (of 1 total)
  • I should add that:

    I have user uploads allowed.
    I have “Resize uploads” set to True.
    I have checked to “pad images smaller than resize set below with a white background?”

Viewing 1 replies (of 1 total)
  • The topic ‘Found glitch. original image not written to server if size matches the default’ is closed to new replies.