Found Bug in WP 2.0 - Image Names Containing Single Quotes Cause Problems (4 posts)

  1. dmetzcher
    Posted 10 years ago #

    I uploaded an image with the following name "Running 'sudo periodic daily' in the Terminal". When I uploaded the image, I was unable to use the image upload interface to add the image to my post. I would click the image, and nothing would happen. I verified that this issue was present in Firefox 1.5 and Safari 2, both on Mac OS X. I also verified that other posts with images worked just fine, until I clicked Browse All, and then none of the images, on any posts, would display the popup menu asking me what I wanted to do with it. This was not just affecting the image with the name containing the single quotes, it was affecting all images displayed along with that image in the upload window. If that image was not present in the list, the other images worked fine.

    I corrected this by going into the wp-posts table in the WordPress database and looking for the post (post_status=attachement) that contained the information for my image. I edited the record in question, taking out the single quotes in the name, and everything was back to normal.

    Not sure what caused this, but it should be pretty easy to reproduce. I wanted to post it, but was not sure where, so I dropped it here. I hope one of the devs finds it.

    Also, so I know in the future, how to we submit bug reports?


  2. vkaryl
    Posted 10 years ago #

    Generally, http://trac.wordpress.org/. You may need to set up an account for login, I'm not sure.

  3. xhale
    Posted 10 years ago #

    You, sir, rock my socks.

    Woooooo! I've been tearing my hair out over this all day. http://wordpress.org/support/topic/58650

    thank you!

  4. dmetzcher
    Posted 10 years ago #

    Glad I could help out. I'm usually the one posting questions and looking for others to help me, so I'm glad that I've finally contributed something. :-)

    I submitted a bug to the WP group, so hopefully this will be corrected in the next bug fix release. Until then, leave out the single quotes. That worked for me.

Topic Closed

This topic has been closed to new replies.

About this Topic