Support » Plugin: LiteSpeed Cache » FOUC – Flash of Unstyled Content Issue

  • I had LSWS installed this weekend and I notice that the Load CSS Asynchronously setting causes my WP theme to show the flash of unstyled content. It seems to be happening on my WP part of my site and not on the forums. Turning off the Load CSS Asynchronously setting resolves the issue.

    I submitted a report to Litespeed. The information is as follows:

    LiteSpeed Report Learn More
    Report number: RLKLIZTT
    Report date: 01/05/2021 07:55:02

    I have tried various combinations of the CSS settings to try to fix the problem as I would like to have the setting Load CSS Asynchronously ON as I noticed the page loads faster that way. So, I am hoping that someone will be able to help me with this. If you visit my site you can see the FOUC in action.

    I did notice this in my source code but I am not sure what it means?

    <style id=”litespeed-optm-css-rules”>/* Failed to trim CSS */</style>

    Thank you for your help in advance.

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Support qtwrk

    (@qtwrk)

    Hi,

    we’ve had some issue on one of our CCSS generation node , please try again now.

    Best regards,

    Thread Starter raptureforums

    (@raptureforums)

    Hello,
    I tried again and it is still showing the same thing. I did view the source again and it shows a different message this time:

    <style id=”litespeed-optm-css-rules”>/* Failed to generate CCSS */</style><link rel=”preconnect” href=”https://fonts.gstatic.com/&#8221; crossorigin />

    Do you have any idea on how I should proceed?

    Thank you for your help. 🙂

    • This reply was modified 6 months, 3 weeks ago by raptureforums.
    Thread Starter raptureforums

    (@raptureforums)

    Hi,
    Just for clarification in the above post, the part of the fonts.gstatic.com URL that shows ” does not show in the source code. I’m not sure how or why it is showing up in the above post as I just paste and copied it in from the source code. Please ignore that part. Thank you.

    Has anyone found a solution for this seemingly common problem. I have checked loads of forums across the internet, with people having the same issue, but no one ever posts the solution.
    I can turn off ‘Load CSS Asynchronously’ and the issue goes away, but if I want to use this feature, I get the FOUC problem.
    Having seen so many threads, it would be really nice if Litespeed would finally offer some kind of solution.

    ArtakEVN

    (@artakevn)

    As I understood there is an issue with the cloud CCSS generator engine and there is not much we can this moment until they improve the CCSS engine.

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.