WordPress.org

Support

Support » How-To and Troubleshooting » Forums won't work in my site, only Admin can see posts – PLEASE HELP!!!

Forums won't work in my site, only Admin can see posts – PLEASE HELP!!!

  • Please help, anyone…I have installed a few different forums, trying to find one that will work. I really wanted to get Mingle Forum to work, but now I’ll settle for anything. Time after time, only Admin can see posts or even the login form. Other users can see the Forum header just fine, but there is nothing else on the page. No one can get access to my forum, I have tried deactivating other plug ins, to see if there is a conflict, and the problem persists. I have gone through all the possible settings a number of times now, and I can’t find anything that might be the problem. I have even scoured the regular support forums trying to find someone with a problem similar to mine that I could perhaps learn from, but apparently, I’m the only one. I’m guessing that since I have the same problem with every Forum plug in, that it’s not the plug ins themselves that are the problem, but I am stumped!! Can anyone help me?

Viewing 3 replies - 1 through 3 (of 3 total)
  • Link? Plugin names?

    Do you have moderation enabled? If so, and if admin hasn’t approved the posts, then admin will be the only one who can see anything.

    http://codex.wordpress.org/Comment_Moderation

    No, there is no moderation enabled at all, anyone can register is enabled, allow people to post comment is enabled, users must be logged in and registered is disabled, I don’t have specific user groups, only the one forum, and it works perfectly when I’m logged in as Admin. What can the problem be? This site is located at schoolofrevnyou.com
    It’s an unfinished site so far, I can’t completely finish it until I get the forum working. I am building this site for my employer, and I’m really starting to look bad, because I can’t resolve this issue. Any help is appreciated

    There may be some issues with a previous forum you’ve installed…
    Do this:
    * Delete all forums and categories
    * Delete all Moderators
    * Delete all Groups
    * De-activate and delete the forum plugin
    * Re-install the plugin

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Forums won't work in my site, only Admin can see posts – PLEASE HELP!!!’ is closed to new replies.
Skip to toolbar