Support » Plugin: W3 Total Cache » Fornt end website showing only funny code when page cacha enabled

  • Hi There

    I have installed W3 Total cache and I have intergrated it with cloud flare. However when page cache is enabled, i just get a heap of code on the website front end. When I am logged in to word press and view the website trough the visit link, the website shows OK, but when logged out of word press it shows the code again.

Viewing 4 replies - 1 through 4 (of 4 total)
  • Hi,

    I may have had a simular problem. Are you using ‘Ithemes Security’ with Theme my login if so uncheck the ‘Hide Login Area’. Having this checked caused a problem and conflict. Also make sure you are clearing the Cloud Flare cache after every change you make. I also might suggest you look at Amazons CloudFront, it seems to work much better that Cloud Flare…

    Hope that helps

    I am using the all in one wp security and firewall plugin. cloud flare recommends W3 total cache, so I dont know what is going on there.

    I have changed to fast cache and used the cloud flare plugin until I can find out what is going on.

    The funny thing is i used the others on another website with the same setting and had no problem, confusing for sure. same host, same theme, same everything.
    I will look at amazon cloud front
    many thanks Paul


    Since both W3 and the All-In One security use Rewrite rules to work the order of plugin activation may change how htaccess is setup and works. Try turning on the security plugin before you tune W3, and also try vise versa – enable W3 and then security. I know with Ithemes Security it automatically preserves htaccess and always puts it settings at the top of htaccess so that plugin enable order effects are minimized. Review your htaccess files on the working sites and compare them with the non working site and I will bet they are different or have a different order…

    I found the problem, my shopping cart plugin was interfering with the W3 total cache plugin. When I deactivated the shopping cart plugin, all was well. I will also try what you said maybe it might help.
    Many Thanks Paul

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Fornt end website showing only funny code when page cacha enabled’ is closed to new replies.