Support » Plugin: Google Forms » formviewer_prd.js link showing before <!– Google Forms JS removal line

  • Below the submit button but before the admin (Edit) link, a link now appears linking to a non-existent JS file.

    Full code:

    <a href="/static/forms/client/js/2874730127-formviewer_prd.js">
    /static/forms/client/js/2874730127-formviewer_prd.js</a>
    <!-- Google Forms unnessary Javascript removed -->
    

    I’ve searched the support threads and also de-activated / removed plugins that might have been causing an issue.

    • This topic was modified 1 year, 6 months ago by  hapatite.
    • This topic was modified 1 year, 6 months ago by  hapatite.
Viewing 12 replies - 1 through 12 (of 12 total)
  • Plugin Author Mike Walsh

    (@mpwalsh8)

    Did you downgrade your Google Form? See this post on my web site. This is another post which also explains the form downgrade process.

    Yep, I downgraded it. I see a large “Try the New Google Forms” at the top of the form now, since I’ve downgraded it. I still had the issue after the downgrade.

    Plugin Author Mike Walsh

    (@mpwalsh8)

    Are you able to share the link to the form so I can look at it? You can send it to me at mpwalsh8 at gmail dot com if you don’t want to post it here.

    sure, here’s the form: Tea Swap Form

    Plugin Author Mike Walsh

    (@mpwalsh8)

    Can you contact me via email offline – I’d like to see the Google Form in the native Google Docs context but don’t think you want to post the URL here. mpwalsh8 at gmail dot com

    Mike,
    Unfortunately, I have the same error.

    When I logged in today, I had a message to update your plugin. I went ahead and did that.

    I then did an edit to one of my forms and while validating it, noticed this message after the form.
    /static/forms/client/js/2874730127-formviewer_prd.js

    Just to debug, I logged out of WordPress and checked again. It was still there.
    I then looked at a different form that I had created and published back on Jan 2 and had not edited since. It is a multipage form. The same message is on the bottom of every page of this old one as well.

    I was already downgraded on the Google Forms. Everything was working great on Jan 2nd.
    Let me know your thoughts.
    Thank you

    Plugin Author Mike Walsh

    (@mpwalsh8)

    As a work-around please try checking the “Disable HTML Filtering” option on the Settings page (Dashboard > Settings > Google Forms) and see if that resolves it.

    Plugin Author Mike Walsh

    (@mpwalsh8)

    Clarification: Make sure that option is checked to enable it.

    What version of WordPress and what version of PHP are you using?

    Well Done…

    Checking off “Disable HTML Filtering?” under (Dashboard > Settings > Google Forms > WordPress Google Form Plugin Settings > Advanced Options) resolved it.

    I am using WordPress 4.7.1 with template Twenty Seventeen 1.0 on PHP Ver 7.0.14
    Thank you for your help!

    Plugin Author Mike Walsh

    (@mpwalsh8)

    I consider that a work-around for now. The link which shows up on some pages shouldn’t with the normal plugin behavior. I have not done any testing with PHP7 so that is my next step. I’ve narrowed it down to where the plugin calls wp_kses() to filter the HTML retrieved from Google. In some instances, the HTML after the filtering is incorrect.

    Thanks, this works for me, too.

    adrienneerin

    (@adrienneerin)

    I had a similar issue where the formviewer_prd.js link was appearing at the bottom of my form. I had added custom CSS styling, but when I checked that box to remove the link, it was removing my custom CSS.

    I solved this by moving the custom CSS to Appearance > Custom CSS in my WordPress settings.

    Just wanted to share in case anyone encounters the same problem I had!

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘formviewer_prd.js link showing before <!– Google Forms JS removal line’ is closed to new replies.