Support » Plugin: Contact Form by WPForms - Drag & Drop Form Builder for WordPress » Forms not being sent from firefox

  • Resolved tokyomagic

    (@tokyomagic)


    I am testing the forms on different web browsers. Firefox appears to be highly problematic, have only received one mailed form from 4 tests. Any idea’s as to why this browser is causing issues?

    The page I need help with: [log in to see the link]

Viewing 3 replies - 1 through 3 (of 3 total)
  • Hello @tokyomagic,

    Thanks for writing in.

    Do you by any chance have an SMTP plugin set up on your site? Because, this might not be a browser issue but more of an email delivery issue.

    To troubleshoot the issue, you can check that your form notification settings are configured correctly by following our tutorial.

    If your notification settings are correct, the issue is likely because the emails sent from WordPress are not authenticated (unlike emails sent from dedicated email service providers). As a result, they are likely to be filtered by the receiving mail server.

    To resolve email delivery issues like this, you can configure a SMTP plugin on your site so that emails are sent as authenticated. We have an article with a list of recommended SMTP options and links to their setup tutorials.

    I hope this helps :)`

    Thread Starter tokyomagic

    (@tokyomagic)

    I don’t have the SMTP plugin installed as I have different forms pointed at different email boxes.

    As for the mails being filtered, they are not landing anywhere in the inbox.

    I will have a look at the article to see if I can get it working.

    thank you for the reply.

    Paul.

    • This reply was modified 6 months, 3 weeks ago by tokyomagic.

    Hi @tokyomagic,

    I hope the email delivery is fixed once you’re able to setup the SMTP plugin. I’m going to go ahead and close this thread for now. But if you’d like us to assist further, please feel welcome to continue the conversation.

    Thanks!

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Forms not being sent from firefox’ is closed to new replies.