Support » Plugin: Contact Form 7 » Forms no longer working after 4.9 upgrade

Viewing 15 replies - 1 through 15 (of 15 total)
  • +1 : messages are not being sent on some of my websites, and I had to downgrade the plugin to get forms working again. It seems this has to do with host settings, so if something has to be asked for from the hosting companies, please tell us so !

    I’m also experiencing a failure.

    If you complete the form and click submit, the page loads, it seems to submit but then returns with a blank form and no confirmation or error message.

    Same problem.

    wordpress 4.8.1
    contact form 4.9

    Same here. WP 4.8.1, Contact Form 4.9.

    Please fix ASAP. This is affecting several dozen sites on a multisite install.

    Same issue. 🙁

    install rollback plugin and revert to version 4.8.1

    CF7 stopped working for me after updating to v4.8 of the plugin. I’ve tried updating to v4.9 and send still isn’t working with a constantly spinning wheel icon. To get CF7 forms working on my sites I’ve had to roll back to v4.7 of CF7 (using rollback plugin, which is a life saver!).

    Looking at the changelog, I wonder if the reason v4.8 onwards of the plugin doesn’t work is because it’s stopped using jquery.form.js.? Or is it due to one of the other changes introduced with v4.8??

    It’s not a problem at the moment as v4.7 is still working fine on my site, but obviously it’s a concern as I like to keep all plugins up to date.

    I had the same issues with wordpress 4.9 and cf7 version 4.9.2. I fixed it with reactivating the json api. Maybe you blocked the api for security reasons with some kind of plugin aswell, but it looks like cf7 needs the api.

    @awpcoder if you could be more specific.

    Using a site with Mandrill and had this problem.

    Fixed by downgrading to 4.7

    Not an ideal solution, but it works now.

    I had to downgrade to 4.7 as well, after combing through all the forums I could on this topic. I was using v5.0 but the forms wouldn’t submit on Safari. Would love it if someone could provide a solution for the current version.

    I am facing the same issue..
    Any fix for this .

    Also having a problem with the submit button. The following error is thrown in the Developer Tools Console

    Uncaught TypeError: Cannot read property ‘into’ of null
    at ajaxSuccess (scripts.js?ver=5.0.3:238)
    at Object.<anonymous> (scripts.js?ver=5.0.3:355)
    at i (jquery.js?ver=1.12.4:2)
    at Object.fireWith [as resolveWith] (jquery.js?ver=1.12.4:2)
    at y (jquery.js?ver=1.12.4:4)
    at XMLHttpRequest.c (jquery.js?ver=1.12.4:4)

    rolling back to v4.7 produced this error when I click submit:
    JQMIGRATE: jQuery.parseJSON requires a valid JSON string

    “I had the same issues with wordpress 4.9 and cf7 version 4.9.2. I fixed it with reactivating the json api. Maybe you blocked the api for security reasons with some kind of plugin aswell, but it looks like cf7 needs the api.”

    Can we get more details about how to do this?

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘Forms no longer working after 4.9 upgrade’ is closed to new replies.