Support » Plugin: WooCommerce PDF Invoices & Packing Slips » Forms from other plugin showing

  • Resolved BSR

    (@biblestudyradio)


    I have just added a shipping plugin which produces a label. However, they are not supposed to show on the Order main page. See image below. The two with PDF symbols are your plugin. The other two are from another plugin.

    https://i.imgur.com/uMszaOz.jpg

    According to them, they did not display it. The only plugin that displays forms is this invoice and packing slip plugin. It seems your plugin is showing labels from another plugin. How to fix this? Thanks.

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Ewout

    (@pomegranate)

    Hi! It’s quite unlikely that this is caused by the PDF Invoice plugin. The PDF Invoice plugin merely hooks into the default action column from WooCommerce, which for orders that haven’t been paid yet also shows the “Processing” and “Completed” buttons:

    It does not magically read or expose any other buttons unless they themselves hook into the action hooks that the PDF Invoice plugin provides for this. You could temporarily disable the PDF invoice plugin to see if their buttons still show. If they do, please let us know the name of the plugin and provide a download link so that we can check the source code to see how this happens.

    BSR

    (@biblestudyradio)

    Hi I deactivated it and the buttons were still there. Does this mean it is their issue or yours?

    Plugin Support kluver

    (@kluver)

    Hi @biblestudyradio,

    Could you please let us know the name of the plugin and provide a download link so that we can check the source code to see how this happens?

    BSR

    (@biblestudyradio)

    Sorry for the delay reply. I think the problem is with their plugin. When I deactivated their plugin, the ghost icons disappeared. It is a UPS WooCommerce paid plugin so you won’t be able to download it.

    I have been trying to convince them it’s their plugin issue 🙂

    Plugin Author Ewout

    (@pomegranate)

    Thanks for the reply! Perhaps the person from support does not have the “Actions” column enabled (top right > Screen options > Actions), and thus not seeing any buttons? I hope they can help you resolve this. Since you mentioned it’s a problem with the UPS plugin, I’ll close this thread for now.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Forms from other plugin showing’ is closed to new replies.