Support » Plugin: Forminator - Contact Form, Payment Form & Custom Form Builder » Forms are not being emailed to us

  • Resolved thefalconrycentre

    (@thefalconrycentre)


    Hello,

    All of our forms have been working fine up until a couple of days ago, and now suddenly we are not receiving any emails when a form has been submitted. Not from any of them, and we have multiple forms for different payment and contact options.

    We only realised this is happening because we get an email notification from Stripe to say a payment has been received, but the customer details for their vouchers etc are not coming through to us. Nothing has changed with our website or email server and they are not ending up in junk or anything like that.

    It is really slowing down processing things that we have to log into the website and find the corresponding form submission. In addition, not all of our forms have a payment linked to them, so we may miss potential customer enquiries as a result of not getting the email. A speedy resolution would be greatly appreciated. Thank you!

    The page I need help with: [log in to see the link]

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Support Pawel – WPMU DEV Support

    (@wpmudev-support9)

    Hello @thefalconrycentre !

    I’m sorry to hear that you’re experiencing this issue!

    It’s odd that this has happened suddenly, though we’ve seen such cases as well.

    Are you using a SMTP plugin on the site to send the emails? It may be due to the default method not being enough to ensure deliverability – too many people were abusing this way of sending emails from WordPress to spam, so many email providers are very sensitive to any issues with emails sent using PHP and the default server method. Usually a SMTP plugin will solve those kinds of issues as it’s basically the same as sending an email from an app.

    There are many such plugins available for free here, we also have one which comes with this functionality – Branda
    Here’s how to setup SMTP sending with Branda: https://wpmudev.com/docs/wpmu-dev-plugins/branda/#smtp

    Kind regards,
    Pawel

    Thread Starter thefalconrycentre

    (@thefalconrycentre)

    Hello Pawel,

    Thank you for the assistance – I have installed Branda and tested it, and it working perfectly now. Much appreciated, thank you!

    Kind regards,

    Gem

    Plugin Support Patrick – WPMU DEV Support

    (@wpmudevsupport12)

    Hi @thefalconrycentre

    I’m glad that this issue is resolved.

    If you have a moment, I would very much appreciate it if you could quickly rate our plugin. This will help us keep the plugin available for free.

    https://wordpress.org/support/plugin/forminator/reviews/#new-post

    Best Regards
    Patrick Freitas

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.