WordPress.org

Support

Support » Plugins and Hacks » RPS Include Content » [Resolved] Formatting problems

[Resolved] Formatting problems

Viewing 15 replies - 1 through 15 (of 21 total)
  • Plugin Author redpixelstudios

    @redpixelstudios

    Not certain why that would be happening. We did some testing on our install and did not find that the formatting of the included post was lost. It may be something specific with your configuration.

    To further troubleshoot the issue, we will need to know what version of WordPress and RPS Include Content you are using. It may also be helpful if you could provide a link to the included post and to the post where the include appears. Pointing out what formatting is lost could be of benefit as well.

    Thanks in advance for your time.

    I have the same problem.

    WP 3.5.1
    RPS 1.0.12.

    I’m trying to include one page into another.

    Plugin Author redpixelstudios

    @redpixelstudios

    Could you could provide a link to the included post and to the post where the include appears? Pointing out what formatting is lost will help. Thanks.

    It’s a local xampp environment and I don’t have a production environment that I can show you.

    The post has all the formatting but once it’s included the formatting is all gone.

    It works like it should except for the formatting.

    There’s a bug.

    This plugin doesn’t take into account that WordPress adds paragraph tags at a later time. That’s why the formatting on my paragraphs were lost.

    After disabling all other plugins, I tried this with a default install of WordPress and this plugin.

    I specifically put in all the paragraph tags where they were supposed to be using the Text Editor, then I published the page. Once the page is included it works just fine as long as I NEVER use the VISUAL EDITOR and ONLY use the TEXT EDITOR.

    Once I use the Visual Editor, WordPress will strip all of the paragraph tags out and if you include it in another page, you will have no formatting.

    Either WordPress needs to stop stripping paragraph tags when using the Visual Editor (who knows when this will happen) or this plugin needs to take in account that WordPress adds paragraph tags at a later time.

    Plugin Author redpixelstudios

    @redpixelstudios

    The plugin relies on default “the_content” filter being executed at the default point in the data retrieval and page display. Is it possible that “the_content” filter has been modified in the theme that you are developing or using?

    Plugin Author redpixelstudios

    @redpixelstudios

    We just ran a test using WordPress 3.5.1 with the 2012 theme and were unable to replicate the issue that you are experiencing. We formatted the content using bold, italic, paragraphs and an unordered list within the visual editor. The formatted post was included via shortcode into another post and the applied formatting was preserved.

    You indicated that you used a default install of WordPress and had disabled all other plugins, but you did not specifically indicate what theme was active. Please understand that we must be able to replicate the issue that you are having in order to resolve it.

    Thanks in advance for your time and effort.

    I am having the same issue.

    See original page and page where it is included

    As you can see, text formatting is lost. I haven’t done any extensive research to see if this is true with all posts/types and for all content, but this was my first try of the plugin.

    This looks like a great plugin that could make a lot of good. I hope this can be resolved.

    Same issue here.

    WP 3.5.1
    RPS 1.0.12

    Origin post. Resulting post (the Cherry Blossom Watch Update title and content of that section)

    Plugin Author redpixelstudios

    @redpixelstudios

    I think that we have a solution for everyone. The newest release of rps-include-content, version 1.0.13, has a shortcode attribute that allows you to force the included content to be passed through “the_content” filter before being displayed. You will need to apply the attribute like so:

    [rps-include post=100 filter=true]

    Let us know if this fix works for you as we realize each configuration may be slightly different. Thanks in advance for your patience and feedback.

    Yes, I can confirm it works for me (check my links again above, now formatting is the same on both).

    Now all I need is a dropdown in the tinyMCE for convenient searching for content and fetching shortcodes, then this would be magic! 🙂

    Thanks!

    Steve

    In my case, it fixed the paragraph breaks but introduced other issues.

    1. The title no longer shows (ie. title=true has no effect).
    2. It’s now adding a page navigation that is on the origin page but isn’t part of the main content input through the post editor.
    3. filter=false has no effect, so I can’t roll these back.

    I’m not sure whether this makes a difference, but I’m using this in a multisite setup so am specifying a blog ID. But it’s the same site, not one of the others in the network.

    Plugin Author redpixelstudios

    @redpixelstudios

    pxlar8,
    The problem with the title was an error that has been fixed in 1.0.14 (will be released shortly). Thanks for notifying us of that issue.

    The page navigation might somehow be getting appended to the content but there is no way for us to know for certain without looking at the theme templates and plugins that are responsible for generating the navigation. Is your theme one that we could get access to?

    You should be able to roll back the changes by removing the “filter” attribute from the short code and updating the post. Is it possible that a cached version of the page is being displayed?

    Great! Will give 14 a try and see how that goes. In the meantime, I’ve just rolled back to 12.

    I don’t think it was a caching issue–I turned off W3TC, cleared browser cache, etc, but it still kept happening. Will try it again with 14. But I was also trying filter=false when it sounds from your note like I should have just removed filter=true.

    As for the page navigation, it’s being appended by Organize Series. Is there any way to mark up the content of the origin post to exclude sections, or alternatively (and even better) to exclude shortcodes?

    Plugin Author redpixelstudios

    @redpixelstudios

    Let us know if the title display is still problematic. The brief round of testing we did seemed to indicate that it was working as before. (There was some suspicion here that version 13 would be unlucky but nobody vocalized it.)

    It is possible that the same error preventing the title from showing was causing the strange behavior with the way the included content was displaying.

    You have a really good idea regarding the exclusion of shortcodes. Perhaps we can setup another attribute that provides for that option. We will definitely look into it.

Viewing 15 replies - 1 through 15 (of 21 total)
  • The topic ‘[Resolved] Formatting problems’ is closed to new replies.
Skip to toolbar