RPS Include Content
[resolved] [closed] Formatting problems (22 posts)

  1. pcopeland
    Posted 3 years ago #


    When i trying using this and including a link to a very small test include I am seeing all the styles/formatting on my original page being lost.

    Any suggestions?


  2. redpixelstudios
    Plugin Author

    Posted 3 years ago #

    Not certain why that would be happening. We did some testing on our install and did not find that the formatting of the included post was lost. It may be something specific with your configuration.

    To further troubleshoot the issue, we will need to know what version of WordPress and RPS Include Content you are using. It may also be helpful if you could provide a link to the included post and to the post where the include appears. Pointing out what formatting is lost could be of benefit as well.

    Thanks in advance for your time.

  3. Mr. Coyote
    Posted 3 years ago #

    I have the same problem.

    WP 3.5.1
    RPS 1.0.12.

    I'm trying to include one page into another.

  4. redpixelstudios
    Plugin Author

    Posted 3 years ago #

    Could you could provide a link to the included post and to the post where the include appears? Pointing out what formatting is lost will help. Thanks.

  5. Mr. Coyote
    Posted 3 years ago #

    It's a local xampp environment and I don't have a production environment that I can show you.

    The post has all the formatting but once it's included the formatting is all gone.

    It works like it should except for the formatting.

  6. Mr. Coyote
    Posted 3 years ago #

    There's a bug.

    This plugin doesn't take into account that WordPress adds paragraph tags at a later time. That's why the formatting on my paragraphs were lost.

    After disabling all other plugins, I tried this with a default install of WordPress and this plugin.

    I specifically put in all the paragraph tags where they were supposed to be using the Text Editor, then I published the page. Once the page is included it works just fine as long as I NEVER use the VISUAL EDITOR and ONLY use the TEXT EDITOR.

    Once I use the Visual Editor, WordPress will strip all of the paragraph tags out and if you include it in another page, you will have no formatting.

    Either WordPress needs to stop stripping paragraph tags when using the Visual Editor (who knows when this will happen) or this plugin needs to take in account that WordPress adds paragraph tags at a later time.

  7. redpixelstudios
    Plugin Author

    Posted 3 years ago #

    The plugin relies on default "the_content" filter being executed at the default point in the data retrieval and page display. Is it possible that "the_content" filter has been modified in the theme that you are developing or using?

  8. redpixelstudios
    Plugin Author

    Posted 3 years ago #

    We just ran a test using WordPress 3.5.1 with the 2012 theme and were unable to replicate the issue that you are experiencing. We formatted the content using bold, italic, paragraphs and an unordered list within the visual editor. The formatted post was included via shortcode into another post and the applied formatting was preserved.

    You indicated that you used a default install of WordPress and had disabled all other plugins, but you did not specifically indicate what theme was active. Please understand that we must be able to replicate the issue that you are having in order to resolve it.

    Thanks in advance for your time and effort.

  9. Stevesan
    Posted 3 years ago #

    I am having the same issue.

    See original page and page where it is included

    As you can see, text formatting is lost. I haven't done any extensive research to see if this is true with all posts/types and for all content, but this was my first try of the plugin.

    This looks like a great plugin that could make a lot of good. I hope this can be resolved.

  10. pxlar8
    Posted 3 years ago #

    Same issue here.

    WP 3.5.1
    RPS 1.0.12

    Origin post. Resulting post (the Cherry Blossom Watch Update title and content of that section)

  11. redpixelstudios
    Plugin Author

    Posted 3 years ago #

    I think that we have a solution for everyone. The newest release of rps-include-content, version 1.0.13, has a shortcode attribute that allows you to force the included content to be passed through "the_content" filter before being displayed. You will need to apply the attribute like so:

    [rps-include post=100 filter=true]

    Let us know if this fix works for you as we realize each configuration may be slightly different. Thanks in advance for your patience and feedback.

  12. Stevesan
    Posted 3 years ago #

    Yes, I can confirm it works for me (check my links again above, now formatting is the same on both).

    Now all I need is a dropdown in the tinyMCE for convenient searching for content and fetching shortcodes, then this would be magic! :)



  13. pxlar8
    Posted 3 years ago #

    In my case, it fixed the paragraph breaks but introduced other issues.

    1. The title no longer shows (ie. title=true has no effect).
    2. It's now adding a page navigation that is on the origin page but isn't part of the main content input through the post editor.
    3. filter=false has no effect, so I can't roll these back.

    I'm not sure whether this makes a difference, but I'm using this in a multisite setup so am specifying a blog ID. But it's the same site, not one of the others in the network.

  14. redpixelstudios
    Plugin Author

    Posted 3 years ago #

    The problem with the title was an error that has been fixed in 1.0.14 (will be released shortly). Thanks for notifying us of that issue.

    The page navigation might somehow be getting appended to the content but there is no way for us to know for certain without looking at the theme templates and plugins that are responsible for generating the navigation. Is your theme one that we could get access to?

    You should be able to roll back the changes by removing the "filter" attribute from the short code and updating the post. Is it possible that a cached version of the page is being displayed?

  15. pxlar8
    Posted 3 years ago #

    Great! Will give 14 a try and see how that goes. In the meantime, I've just rolled back to 12.

    I don't think it was a caching issue--I turned off W3TC, cleared browser cache, etc, but it still kept happening. Will try it again with 14. But I was also trying filter=false when it sounds from your note like I should have just removed filter=true.

    As for the page navigation, it's being appended by Organize Series. Is there any way to mark up the content of the origin post to exclude sections, or alternatively (and even better) to exclude shortcodes?

  16. redpixelstudios
    Plugin Author

    Posted 3 years ago #

    Let us know if the title display is still problematic. The brief round of testing we did seemed to indicate that it was working as before. (There was some suspicion here that version 13 would be unlucky but nobody vocalized it.)

    It is possible that the same error preventing the title from showing was causing the strange behavior with the way the included content was displaying.

    You have a really good idea regarding the exclusion of shortcodes. Perhaps we can setup another attribute that provides for that option. We will definitely look into it.

  17. pxlar8
    Posted 3 years ago #

    14 is working a treat. Titles back and paragraph breaks inserted. Thanks for putting out a fix so quickly.

    In my case, the navigation bar is still be appended, but I can live with that for now. But would love a way to exclude shortcodes--thanks for looking into it.

    Great plugin, by the way. Been waiting for a long time for something like this.

  18. redpixelstudios
    Plugin Author

    Posted 3 years ago #

    That's great to hear. Glad we were able to get a fix in place. You will be glad to know that we went ahead and implemented the option to exclude shortcodes from the included content with version 1.0.15. You will just need to format your shortcode like so:

    [rps-include post=100 shortcodes=false]

    Let us know if you need anything else regarding this issue or feel free to mark it as resolved. Cheers.

  19. blewy99
    Posted 3 years ago #

    This is the perferct plug in for my client but I am having some formatting issues.
    Wordpress 3.5.1
    Theme: Twenty Twelve

    Look going for: http://whyeducatewomen.com/ This is currently 1 page with all the text on that page divided into 3 columns. I would like to get the same effect by using this plug-in that pulls from 3 different posts as the client is only looking to update 1 of the areas on a regular basis.

    When I use the shortcode [rps-include post=1 filter=true], I get this effect: http://whyeducatewomen.com/?page_id=85. I even tried taking the filter=true off and still get the formatting difference.

    Tested in FF and IE (to which I figured out my template doesn't work in IE, go figure.) and got the same formatting result.

    Thank you in advance for your help.

  20. redpixelstudios
    Plugin Author

    Posted 3 years ago #

    Formatting problems can be tough to track down. When filter is set to "true" we are forcing the included content to be passed through "the_content" filter, which shouldn't be necessary in most cases. If it is not too much trouble, could you run our plugin solo and see if the problem remains. Our guess at this point is that it could be a conflict with another plugin that modifies the timing of the content filtering, but there is no way to know for certain without a bit of testing. Thank you for your feedback.

  21. Jeremiah Kephart
    Posted 2 years ago #

    Your plugin is almost certainly the solution I have been searching for for several days now. I am also very impressed by the attention you give to your eagar tech audience. +_+

    I have hit a wall with the shortcode issue, and it may not be your plugin,, but I wanted to see if you had any insights:

    There is a popular podcasting plugin called PowerPress
    It offers two options... 1.) you can allow it to embed a media player linked to your hosted media in the page via a widget available below each page/post (or) 2.) you can use a shortcode to place the same player in a place you specify. '[powerpress]'

    While both of these (mentioned above) work flawlessly inside a test post *seen here
    sadly, neither of these aforementioned delivers the media player to the page containing the RPS Include shortcode.

    The shortcode mentioned is currently
    '[rps-include post=604]'
    though I have been experiementingwith shorcodes as long as
    '[rps-include post="673" shortcodes="true" title="true" titlelink="true" content="lede" length="60"]'
    to attempt to solve the problem.

    I will readily admit that I am not a coder, and so I am not sure how to generate an exception that might let PowerPress import the media player.

    Dashboard > Settings > RPS Include Content
    I see only the two radio boxes listed here:
    [ ] Remove the interface that appears when hovering over included content
    [ ] Show private included content without restriction
    I do not see any other editable settings whatsoever (there is just a blank page after the radio boxes.)
    I am using WP version 3.6

    Thanks for being involved with your users.
    One final question:
    If I wanted some custom development, do you take requests and what are your rates?


  22. esmi
    Forum Moderator
    Posted 2 years ago #

    @Jeremiah Kephart: If you require assistance then, as per the Forum Welcome, please post your own topic. This topic is 10 months old and references a pretty old version of WordPress.


Topic Closed

This topic has been closed to new replies.

About this Plugin

  • RPS Include Content
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic


No tags yet.