Format for "update" (6 posts)

  1. CliffDillard
    Posted 2 years ago #

    I have a form that has a search option to narrow the list of records and then a select (rlink) to edit the selected record. Everything works but I am getting a non-fatal error message on the screen that I would like to eliminate. I am thinking it is due to my misunderstanding the Forms format. Any suggestions?

    [abase form="1,search" table="Detail" columns="ClassYear!'100',FirstName,LastName,MaidenName$Search" elements="ClassYear,FirstName,LastName,MaidenName"]

    [abase table="Detail" limit=200 columns="ClassYear!'100',FirstName,LastName,MaidenName,City,State,Country" ORDER="ClassYear, LastName,FirstName" rlink="FirstName" ack="green"]

    [abase form="1,update" table="Detail" elements="FirstName,LastName,MaidenName,ClassYear,City,State,Country,Email,Memo" fields="FirstName,LastName,MaidenName,ClassYear,City,State,Country,Email,Memo$Update Detail" ack="brown" echo="blue"]

    Error Message:
    #3. #4. [abase form=""1,update"" table=""Detail"" elements=""FirstName,LastName,MaidenName,ClassYear,City,State,Country,Email,Memo"" fields=""FirstName,LastName,MaidenName,ClassYear,City,State,Country,Email,Memo$Update" ack=""brown"" echo=""blue""]
    Non-Fatal Error (1203)
    Attribute form=""1,update"" is incorrect. Use form=",search" or form=",input" or form=",update"., Table "Detail" does not exist. Valid table names in roster2014: Countries, Detail, States.


  2. cswaim
    Posted 2 years ago #

    Looks like you have two sets of double quotes:

    form=""1,update"" table=""Detail"" should be form="1,update" table="Detail"

    check all the fields.

  3. CliffDillard
    Posted 2 years ago #

    I agree that that is what the error message implies but I have checked the code and there is only one quote. If I remove it I get other error messages. Thus my confusion. I was guessing it had something to do with multiple forms on the same page but have tried various combinations with no luck.

  4. Loulou51
    Posted 2 years ago #

    The end of your code is not correct, try .....echo="blue" /]

  5. ronnieg
    Posted 2 years ago #

    On WP 3.8.1, ABASE 2.2.1

    I am getting the same non-fatal errors, with the same extra quote marks inserted by the plugin that are NOT in my shortcode, and appear to be causing ABASE parsing errors. The update form fields are displayed, but there is no Submit/Update button. This problem only occurs for shortcodes with form and its parameters.

    Tried moving the update form to a different page (url specified in rlink parameter on main table page) and that did not help.

    Tried adding slash at end of the shortcode. That makes no difference, and is not included anywhere in the shortcode syntax examples in the FAQs.

  6. sabiha1411
    Posted 2 years ago #

    #1. [abase table="bank" columns="BankName,TodayRate,LacRate" rlink="BankName" echo="blue"]

    why those line's are displayed when i want to update some data ??

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic