WordPress.org

Support

Support » Plugins and Hacks » Form won't show in Google Chrome when logged in

Form won't show in Google Chrome when logged in

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author Michael Beckwith
    Participant

    @tw2113

    What settings are you using for the form? Widget? Shortcode? which attributes if the shortcode?

    Plugin Author Michael Beckwith
    Participant

    @tw2113

    From the looks of the code, we have this line that triggers the similar message:

    if ( !is_user_logged_in() && get_option( 'npu_user_role_select' ) != 99 ) {

    if the person visiting is not logged in, and the user role is not “visitor” aka 99, then display the not logged in message.

    So basically if you want non-registered people to be able to submit anything, the minimum role needs to be visitor. Otherwise they need to be a registered user and logged in.

    jamminjames
    Participant

    @jamminjames

    But it’s not working for logged in people using Chrome.

    I’m using shortcode on the page, simply: [ngg_uploader id = 4], as the gallery id is 4.

    I have it set for a minimum role of Subscriber, Description text field enabled.

    As I say, it works fine for other browsers, just not Chrome.

    Plugin Author Michael Beckwith
    Participant

    @tw2113

    Not sure what to tell you without being able to access it all. We don’t do any sort of hiding or preventing per browser, and it’s all server-side processing.

    jamminjames
    Participant

    @jamminjames

    What do you mean, ‘access it all’? And, have you never heard this complaint about it not working with Chrome before?

    Plugin Author Michael Beckwith
    Participant

    @tw2113

    Nope, this is a first. “access to all” would me being able to log into the site and edit plugin options.

    jamminjames
    Participant

    @jamminjames

    Ok, I can get you the login info, if you promise not to do anything to the other plugins, like deactivate them or mess with settings.

    I’ve already tried deactivating all the plugins and switching to the twenty-eleven theme, to see if there was anything conflicting. It made no difference.

    Btw, I noticed that when logged in as an Admin, it does work. But not when logged in as a Subscriber.

    How do I get you the login info?

    Plugin Author Michael Beckwith
    Participant

    @tw2113

    jamminjames
    Participant

    @jamminjames

    I discovered that actually, the form was not showing up on any browser when logged in, even though I had ‘subscriber,’ the lowest role other than visitor. So, I switched to ‘visitor,’ and now it’s working on all browsers. Sure would be nice to be able to restrict it to logged in visitors, however.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Form won't show in Google Chrome when logged in’ is closed to new replies.