Support » Plugin: Contact Form 7 » Form Stalls on "Submit"

  • I am having an issue with a form stalling on submission. I just get an endless looping arrow cycle. No emails.
    I know this has been posted a few times but none of the threads has helped my situation.
    I am using CF7 3.4.2
    I have activated WP-Mail-SMTP to make sure my email is sending and it is.
    I have tried a very basic form and tried recreating it just to see if that was the issue. Here are the particulars:
    Permalinks are set to: /%category%/%postname%/
    Test form can be seen here:
    Form Code is:
    <p>Your Name (required)
    [text* your-name] </p>
    <p>Your Email (required)
    [email* your-email] </p>
    [text your-subject] </p>
    <p>Your Message
    [textarea your-message] </p>
    <p>[submit “Send”]</p>

    Mail To code is:
    subject: [your-subject]
    Message Body:
    From: [your-name] <[your-email]>
    Subject: [your-subject]
    Message Body:

    Ay help is appreciated.

Viewing 14 replies - 1 through 14 (of 14 total)
  • I thought i would also add I have tried default theme and deactivating all plugins. No difference.

    Have you looked at Contact Form 7 Email Issues?

    Yes i have. Per my posts above you can see most of the issues addressed in the article are not causing the problem.
    The one thing I am trying to check is a script issue using Firebug. I have not used it for debugging script so I am learning how.
    So to review:
    1. Emails do get sent from WP to my hosting server (GoDaddy)
    2. The To and From emails in CF7 are the same as my WP email
    3. Changing Theme or deactivating plugins has no affect.
    4. Engaging WP-Mail-SMTP does not affect problem.

    RE: I just get an endless looping arrow cycle. No emails.

    Sorry – I am still unclear if you are receiving emails or not.

    If others here are able to understand your actual problem, they may be able and willing to offer a possible solution.

    May bad if I was not clear.
    I CAN receive emails through my website from regular mailto links
    I DO NOT get an email when I hit submit using CF7.
    So I am not having the issue I have read where others are seeing the looping arrow but actually getting the submission.
    Is that clear?

    Is your WordPress installation is able to send emails?

    Try going through the “forgot password” function on wp-login.php.

    Do you get the email? If you don’t you will need to rectify this.

    Yes I get email through WordPress.
    Yes I get email through Forgot Password process.
    Again the problem does not appear to be with WordPress, Hosting passing email, Theme or plugins.

    BTW – Thanks Buzztone. So far you are the only one chipping in. I do appreciate it.

    Have you tried using other email addresses?


    The above setup could cause issues on some hosts.

    Yes I tried changing both separately and together.
    Both using hard emails and using [your-email] in the “From”
    No difference.

    Tested your form – looks like classic Javascript conflict.

    May be that Javascript conflict is occuring before CF7 gets to point where it sends email.

    Remember that a problem in one script can cause issues in another. For example, some jQuery errors can stop jQuery processing any more script, which can make the culprit hard to find. A jQuery error in one of your plugins or your themes javascript files can stop jQuery processing before it gets to the CF7 script.

    Outside of deactivating plugins and changing themes, how can I test for this?
    Again thanks for sticking with this.

    Use Firebug or Chrome Dev Tools to examine Javascript conflicts in detail – see Use Firebug or Chrome Dev Tools

    I am sending the form data to a third party program (mine). and everything seems to be working but the form hangs up with the looping icon.

    My program is processing the data from the form correctly but the user does not get any feedback.

    I did add a hook to functions.php with a callback message and I did enter that same message in the third party plugin.

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘Form Stalls on "Submit"’ is closed to new replies.