Support » Plugin: Very Simple Contact Form » Form shows error upon submission, but appears to really be going through

  • Resolved syzygist

    (@syzygist)


    When I tested the contact form after updating from 11.5 > 11.6, I got the following message onscreen upon submission instead of the confirmation message:

    “Error! Could not send form. This might be server issue.”

    This happened on two sites with different themes, plugins, etc., on different hosts. On both sites, despite the onscreen error message, the form did show up in the Submissions list in the WP admin on both sites. The form on the first site linked above was tested and working 10 days ago. It sure looks like this is related to the update.

    The page I need help with: [log in to see the link]

Viewing 12 replies - 1 through 12 (of 12 total)
  • Plugin Author Guido

    (@guido07111975)

    Hi @syzygist

    I had to make some changes to plugin regarding the captcha and other security related stuff. Unfortunately because of that I made a mistake in the coding of the so called FROM email header. Now form submission does not send. I will fix this today!

    Guido

    Plugin Author Guido

    (@guido07111975)

    Hi again,

    Problem is fixed, please update. Thanks for reporting.

    Guido

    Thread Starter syzygist

    (@syzygist)

    Thanks for fixing so promptly. And thanks for the plugin, I really like it. I miss the captcha, though 🙁 Hopefully, someday you will be able to add it back without compromising security.

    Plugin Author Guido

    (@guido07111975)

    You’re welcome.
    In its current form the captcha was giving users a false sense of security and that’s not how it should be. More sophisticated bots were able to bypass it.
    But plugin still has other anti-spam features, so I think this change will not cause spam all of a sudden.

    Guido

    Thread Starter syzygist

    (@syzygist)

    I’m glad to hear that. Comment spam is an ongoing challenge.

    Plugin Author Guido

    (@guido07111975)

    Hi @syzygist

    I miss the captcha, though

    I was wondering whether you’re receiving spam after removal of the captcha, or not?

    Guido

    Thread Starter syzygist

    (@syzygist)

    I have the plugin installed on two sites I manage, both of which have very low traffic of real messages. On the one with the higher expectations of real messages (1-3 per month), I have seen no increase of spam. However, on the other site (averages 2-3 real messages per year), I have seen a considerable increase of spam messages (8 in the past month). This is the count in the Submissions pane – I am assuming that if they show there, they went through to the site owner.

    Plugin Author Guido

    (@guido07111975)

    Thanks for the update.
    Maybe those 8 spam submissions were done by human spammers, that’s almost impossible to block with captcha. Yes, I can check message content for spammy links (URL’s) and filter on that (for example, block if more than 1 link), but that requires much work.
    I’m planning to re-add the sum (1+5=), but more complex bots can handle this unfortunately. But it will certainly block some bots.

    Guido

    Plugin Author Guido

    (@guido07111975)

    Hi again,

    8 in the past month

    Do those submissions contain full links to spammy websites? Because normally my plugin removes all HTML tags from those links. In short, only regular text and line-breaks are allowed there.

    UPDATE:
    Although HTML tags are removed, submission can still contain multiple not-clickable links. I can add an internal counter for links, more than 1 link in text area field = spam (for example).

    Guido

    • This reply was modified 2 months, 4 weeks ago by Guido. Reason: Have updated this reply
    Thread Starter syzygist

    (@syzygist)

    They look like automated spam to me, primarily for random products and services, mostly unrelated to the site. Most had two links, but one had three, and one (which was mostly in Russian) had only one link. However, legitimate messages could conceivably have more than one link, so that doesn’t seem like the ideal filter.

    Plugin Author Guido

    (@guido07111975)

    I think this can be a nice addition, but only when site owner has control over this. So when adding this I will give options as well (such as: allow, disallow, allow 1 link only).

    Guido

    Thread Starter syzygist

    (@syzygist)

    That makes sense. Thanks for continuing to work on this. I really appreciate how you are always improving the plugin.

Viewing 12 replies - 1 through 12 (of 12 total)
  • You must be logged in to reply to this topic.