Support » Plugin: Form Manager » form resetting instead of submitting when filled in on iPad

Viewing 11 replies - 1 through 11 (of 11 total)
  • Just an update on this. Apparently Firefox users are experiencing the same issue…form not submitting. I’m about to jump ship to another form processor…any chance you can look into this issue Campbell? Thanks!

    Update # 2. I managed to get this form to work by turning off the “Auto Redirect” to a new page. I typically turn this on and set it to 0 seconds so the user will be immediately taken to the page I want.

    By turning off Auto Redirect and putting the confirmation text in the “customize Submit Acknowledgement Message” field at the bottom this fixed my issue. (Glad that field can use custom html so I could make it look the way I wanted.)

    So I guess this is a workaround and the issue here is that Auto Redirect is not working with this form. Not sure if it’s a conflict with another plugin to ??

    Update # 3

    So it looks like the turning off “Auto Redirect” did not actually do the trick as a few users notified me it wasn’t working. Tried myself and when I submit the form using certain web browsers (Firefox on Safari or Chrome on iPad for example) the form just resets instead of submitting and displaying the confirmation message.

    I had to put up a different form in it’s place using a Google Form as this is a live project and I needed it to work now.

    BUT in the meantime I’d still rather use WP Form Manager as it’s much more robust in what I can do with it (especially email notifications). SO I put the WP Form Manager version of the form up here in case you get around to taking a look at it:

    http://poetrysuperhighway.com/psh/form-manager-test/

    Cheers,

    Rick

    Plugin Author hoffcamp

    (@hoffcamp)

    99% of issues are because there is no call to wp_footer() in the theme’s footer. This is where the form specific scripts are placed.. but I’m not sure that this would cause your issue. If you put the form back up I’ll take a look.

    Hi Campbell,

    Sorry I had made the page “private”…it’s unprivated now…thanks for taking a look: http://poetrysuperhighway.com/psh/form-manager-test/

    Plugin Author hoffcamp

    (@hoffcamp)

    I just took a look at the page. I’m not sure what is causing the problem, though I suspect something incompatible with another plugin’s JavaScript. The next step I would take is to disable other plugins and see if that solves anything.

    I did try the auto redirect with an iPad using my testing server, and it does work in that setup. There are so many other variables though that I can’t rule out something broken in my code, I just can’t reproduce the issue myself.

    Hi…thanks for checking on this. Did you try with Firefox?

    Plugin Author hoffcamp

    (@hoffcamp)

    I used Firefox 29 on Win8.

    OK so I just went to the test form link using Firefox (v 30.0) on my iMac using the latest version of Mavericks and the form reset instead of submitting.

    Then did it a second time and it went through with the Thanks confirmation message.

    Does that tell us anything about why it might be happening?

    Could it have anything to do with certain types of text (quotation marks or apostrophes or slashes) causing an issue when included in form entries?

    I tried duplicating what I entered the first time and it seemed to work….server issue??

    Plugin Author hoffcamp

    (@hoffcamp)

    Are you using an HTML cache somewhere?

    Yes.

    I use W3 Total Cache.

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘form resetting instead of submitting when filled in on iPad’ is closed to new replies.