Support » Plugin: Contact Form 7 » Form only submits when logged in

  • Hi there, my form here wineeducationaustralia.com only submits when I’m logged in. When I’m logged out, the form does not submit and I get the spinning wheel. I’ve tried to deactivate all plugins and switch to standard theme, then reactivate all, and the form still doesn’t work. Can anyone help? Thank you

    The page I need help with: [log in to see the link]

Viewing 5 replies - 1 through 5 (of 5 total)
  • Hi @edgecliffroad, I have exactly the same problem that you describe.
    I solve it, adding this code in functions.php:
    add_filter( 'wpcf7_load_js', '__return_false' );

    What is causing this, are some security improvements made in CF7 v4.8. Since that version, CF7 utilizes WP REST API to AJAX updates. If you take a look at the console log, you will see that it tries to access to wp-json directory, with no success.

    There are other solutions, like modify the .htaccess file to allow access to that directory, but I think that the easiest is the one that I told you first.

    If anyone has a better solution, please share it in this message.

    Thanks,
    Good luck!

    Thread Starter edgecliffroad

    (@edgecliffroad)

    hi @capiedge – yes I tried this by updating the wp-config-file-7.php file in the plugins folder and simply modifying this line define( ‘WPCF7_LOAD_JS’, true ); to become define( ‘WPCF7_LOAD_JS’, false );

    This enables the form data to be submitted, and I receive the email, but any redirection to a thank you page then does not work and I can’t track the form submissions via analytics. Which is an issue for me.

    I need the redirect to work as well if at all possible. Does anyone else know of a solution?

    When I’m logged out, the form does not submit and I get the spinning wheel.

    The spinning arrow is a common sign of a JavaScript conflict. Only submitting when logged in also indicates a JavaScript conflict.

    I’d suggest you try disabling all plugins & switching to a default theme again when not logged in. Health Check is a good way to check this on a live site. It’s planned to be made part of WordPress Core in coming releases.

    Make sure you also disable any caching (especially if done via a WP plugin).

    The solution offered by capiedge just activates a standard filter option available in CF7, which disables all CF7 JavaScript – see Loading JavaScript and Stylesheet Only When it is Necessary

    If does not address any particular problem on your site (it just hides the symptoms) & you will lose all of CF7’s Javascript functionality which is important for things like form validation.

    • This reply was modified 3 years, 12 months ago by Neil Murray.
    Thread Starter edgecliffroad

    (@edgecliffroad)

    Yes @buzztone I disabled all plugins and switched to the standard wpress theme. The form worked. I activated each plugin one by one and tested each activation. The form worked. The issue appears to be coming from the theme I use which is called – Bridge. I have older Bridge version websites with the same CF7 forms working fine, with redirection. I’ve ticketed the QODE developers and will see what they say. Incredibly frustrating though

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Form only submits when logged in’ is closed to new replies.