Support » Plugin: Easy Forms for Mailchimp » Form Not updating after changes on Mail Chimp

  • Resolved bnisia

    (@bnisia)


    Form elements have been changed and removed from MailChimp but the old elements are still showing we have turned on debugging and so far no errors, I have also attempted to clear the cache. (both of the api and rocket cache and my browser)

    the customer is eager for a solution.

    There is code like this on the back end presumedly the get_list_data is not getting the latest?

    <?php
    				$list = get_list_data(array(
    					'path'=>'convert-your-data'
    				));
    				if($list->have_posts()){
    					$r = 0; 
    					while ( $list->have_posts() ) {
    						$list->the_post();
    						$data = $list->post; 
    						$meta = get_post_meta($data->ID);
    						$next_page = (!empty($meta['next_page'][0])) ? "page_".$meta['next_page'][0] : "";
    						$prev_page = (!empty($meta['prev_page'][0])) ? "page_".$meta['prev_page'][0] : "";
    						$item_class = (!empty($meta['item_class'][0])) ? $meta['item_class'][0] : "";
    						$page_class = ($r== 0) ? "active-page" : "next-pages"; 
    						echo "<div class='col-md-8 cool-article page-item page-step-".$r." ".$item_class ." ".$page_class."' data-next='".$next_page."' data-prev='".$prev_page."' data-index='".$r."' id='page_".$data->ID."'>";
    						echo  the_content(); ///$post->post_content;
    						echo "</div>";
    						$r++; 
    					}
    					wp_reset_query();
    				}
    				?>

    The page I need help with: [log in to see the link]

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author jpowersdev

    (@jpowersdev)

    Hi @bnisia,

    Have you tried editing the form through our plugin? If the fields have been changed in Mailchimp, you should see those updates in the form editor.

    Jon

    Thread Starter bnisia

    (@bnisia)

    No it is showing the old values in spite of update to the MMERGE7 form element (a radio block) if that makes any difference

    Thread Starter bnisia

    (@bnisia)

    I wish these forms allowed images to be posted but here is the confusing part on the staging version of the site it shows the new version of the form fields in the editor (but still displays the old on the front end) however on the live one it does not show the new values … I
    yes in the editor it does not show the new values for the MMERGE7
    item. And even when I replace it with a MMERGE29 with the new parameters
    its still not showing them correctly on the front end.

    the part of the code that I posted earlier which seems like it might be failing is this it not sure where convert-your-data array is being created.

    $list = get_list_data(array(‘path’=>;’convert-your-data’));

    I am wondering where that get_list_data is getting it from.

    • This reply was modified 5 months ago by bnisia.
    Thread Starter bnisia

    (@bnisia)

    Never mind customer had basically over-ridden the plugin

    Plugin Contributor Tracy Levesque

    (@liljimmi)

    🏳️‍🌈 YIKES, Inc. Co-Owner

    Oops! I’m glad you were able to figure it out though!

    Take care.
    -Tracy

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.