Support » Plugin: Forminator - Contact Form, Payment Form & Custom Form Builder » Form not showing with .forminator-error class

  • Resolved dgedgw

    (@dgedgw)


    Hi,
    I have a forminator form for an application form, which uses multiple pages and PayPal payment integration at the end. From time to time, the form will not show, with a blank bloc instead with the class .forminator-error:

    <div class="forminator-gutenberg>
    <form id="my form ID">
    <div class="forminator-response-message forminator-error"></div>
    </form>
    <div>

    I’ve tried to deactivate my cache plugin (although form should not be cached) and it doesn’t change anything. I cannot figure out why it is happening. Could you help me with this?

    Thanks in advance!

    The page I need help with: [log in to see the link]

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Support Pawel – WPMU DEV Support

    (@wpmudev-support9)

    Hello @dgedgw !

    I hope you’re doing well today!

    I’ve checked the page you’ve shared and I think I’ve found the cause of the issue:

    In the console, there’s an error saying that the request for the form’s code (to wp-admin/admin-ajax.php) has been blocked and is returning a 403 error code.

    403 means that there’s some security plugin or a firewall that’s blocking the request – what we call a “false positive”.

    Please check:
    – whether deactivating security plugins helps
    – with the hosting support to make sure they aren’t blocking the request by accident

    This is not strictly Forminator related, but I’d suggest to check this in more detail as requests to the Ajax endpoint are a crucial part of WordPress and are required for many core functionalities and plugins to work correctly. My guess is that it’s just too tight security on the server 🙂

    Kind regards,
    Pawel

    Thread Starter dgedgw

    (@dgedgw)

    Hello Pawel,
    thanks for your answer! I need to check with the sysadmin if it due to security settings on server side. I’ll give you feedback as soon as I know!
    Kind regards

    Plugin Support Nithin – WPMU DEV Support

    (@wpmudevsupport11)

    Hi @dgedgw,

    Sure, sounds good. Feel free to get back once you get more info.

    Kind Regards,
    Nithin

    Thread Starter dgedgw

    (@dgedgw)

    Hi,
    the issue was due to security settings on server side, as the wp-admin folder access was only enabled to some IPs.
    Thank you for your help!
    Kind regards

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.