Support » Plugin: IP Geo Block » Form not sending – jquery.js

  • nesoor

    (@nesoor)


    Hello WordPress Members,

    GEO IP is blocking “jquery.js” and because of that my form isn’t sending the data.
    Any idea how I can add “jquery.js” to the whitelist on GEO IP.

    Request
    POST[443]:/wp-admin/admin-ajax.php
    User agent
    Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/70.0.3538.77 Safari/537.36
    HTTP headers
    HTTP_REFERER=https://www.domeinnaamhier.nl/aanmeldformulier/,HTTP_ORIGIN=https://www.domeinnaamhier.nl,HTTP_X_REQUESTED_WITH=XMLHttpRequest
    $_POST data
    action=elementor_pro_forms_send_form,FILES=Array ( [form_fields] => Array ( [name] => Array ( [field_17] => ) [type] => Array ( [field_17] => ) [tmp_name] => Array ( [field_17] => ) [error] => Array ( [field_17] => 4 ) [size] => Array ( [field_17] => 0 ) …

Viewing 2 replies - 1 through 2 (of 2 total)
  • nesoor

    (@nesoor)

    jquery.js?ver=1.12.4:4

    Plugin Author tokkonopapa

    (@tokkonopapa)

    Hi @nesoor,

    The most easiest way is to disable “Prevent malicious file uploading” in “Validation rules and behavior” section. It does not mean the site is immediately at risk unless plugins or themes have vulnerability.

    Alternatively, the best way is to give permission under the certain condition.

    Please try the following:

    1. Download drop-in-admin.php from here and unzip it.
    2. Upload drop-in-admin.php into the geolocation API directory (/wp-content/ip-geo-api/ or /wp-content/uploads/ip-geo-api/).

    It enables you to skip validating “Prevent malicious file uploading” if the current user is admin using Elementor Page Builder.

    Thanks for the asking.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Form not sending – jquery.js’ is closed to new replies.