Support » Plugin: Contact Form With Captcha » Form not sending any email content

  • Resolved griffindog

    (@griffindog)


    The form has been working on our site for months. All of a sudden it has stopped sending any email content. When forms are submitted, we get an email with this information:

    Sender Name: (blank)
    Sender Email: (blank)
    Sender IP Address: xxx.xx.xxx.x (Find location for this IP)

    That is the extent of the emails that are coming in. No information transmitting.

    We have the current plugin version.

    https://wordpress.org/plugins/contact-form-with-captcha/

Viewing 4 replies - 1 through 4 (of 4 total)
  • Similar thing happened here. It was working fine in our tests, so we stopped paying attention. Then we decided to test it since we hadn’t received emails in a while. It said that message sent, but no message was received.

    Is this a WP update issue?
    When I discovered the problem, I went to look at the admin panel. On the part that says, “Do not give credit to developer (Please consider NOT checking this box)” there was an error: “Warning: Illegal string offset ‘text_string’ in …wp-content/plugins/contact-form-with-captcha/cfwc-main.php on line 197”

    A search of that error came up with the following answer from 7 months ago: “I’ll comment it for now in next update as I am not using it anyway.”

    I uninstalled and reinstalled. Since a fresh install of the plugin resulted in the same error, I went to line 197 and commented it out. The error went away, but still no email. Several other attempts to troubleshoot have so far been unsuccessful.

    Another thing I noticed was that when I uninstalled and reinstalled, all my settings stayed the same. That means that it remains in the database even after uninstalling.

    Could it be a GoDaddy php issue? I’ll keep working on it and let you know what I find out…

    I’ve deactivated the plugin for now to implement another way to be contacted.

    Okay…
    Of course it’s due to my error! I moved from one server to another, and the new server is using cPanel. I needed to go into the MX Entry part of the cPanel Email section and change the setting for all my domains to “Remote Mail Exchanger”. Now all is good again.

    Thanks for a GREAT plugin!

    I wish that was the solution for me but we’re receiving emails, there’s just no content in them. Hoping someone will reach out with a solution soon.

    Plugin Author Technology Blog

    (@zackhasit)

    Good to hear it worked.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Form not sending any email content’ is closed to new replies.