Support » Plugin: Contact Form 7 » Form not sending

Viewing 12 replies - 1 through 12 (of 12 total)
  • same here – it was working yesterday, nothing happens after you press send today

    Having the same issue here, I guess. When I hit the send button the loading icon just keeps on spinning forever. No errors or info in the console. If I disable javascript the form is working fine.

    We’re also experiencing the same issue. Version 4.8 is not submitting the form.

    When can we expect a fix to 4.8?

    sooo? where’s the support team?

    If the form works when you’re logged in, and not when you aren’t, and you’re using any plugin/method of disabling access to the anonymous REST API for security reasons, you may be experiencing a problem with CF 7’s use of the anonymous REST API.

    Rolling back to version 4.7 of CF 7 will fix the problem while we wait to see what the developer does about it. He has been silent thus far about the issue. There are a bunch of threads about it.

    Thanks, but no – it never works. I keep getting spam though, not sure how they do it

    How can I roll back?

    How can I roll back?

    If you don’t have the anonymous REST API issue, rolling back may not help you. You may have some other plugin or theme conflict.

    The CF 7 4.8 -> 4.7 rollback is easy since there don’t appear to be any database changes. As with any plugin, you go to the plugin home page, click the “Advanced View” link in the right sidebar, scroll down to “Previous Versions,” and download the version you want to use.

    Then, it’s a matter of deleting the files for the current version of the plugin and uploading the version you want to use. If you have a hosting control panel like cPanel, the fastest way I’ve found is to upload the entire zip file for the version you want to roll back to to your /wp-content/plugins folder, use the File Manager of your control panel to delete the /wp-content/plugins/contact-form-7 folder, extract the zip file, and then clear your cache if you’re using some form of caching. There are also plugins that will roll back versions.

    Thanks, but it stopped working yesterday and it worked before.

    The CF 7 4.8 -> 4.7 rollback solves the problem.
    Thank you, linux4me2!

    Well, rolling back was plan C for me, but since I need this beautiful plugin I tried it today and now it works again (v.4.7). I might not like it, but hey… I hope there’s a fix for this soon 🙂

    Cheers o/

    I have shared this issue in other threads and wanted to share here for the sake of OP and others: I can confirm the same issue after upgrading to 4.8. Emails are sending fine, but the progress animation continues to spin for all forms with no confirmation/success message displayed.

    I figured this might be related to the change to REST API. We had REST API disabled due to previous security concerns. Turned it back on after disabling and clearing all local and server caches, still had issues with 4.8.

    After a bunch of testing, nothing helpful popped up in console or in error logs, so have reverted to version 4.7 of CF7. Back to working fine. I’m not sure what’s going on there but it seems to be related to changes in the plugin between these versions.

    If anyone needs a quick way to rollback, I recommend this plugin: https://wordpress.org/plugins/wp-rollback/

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘Form not sending’ is closed to new replies.