Support » Plugin: CRM Perks Forms - Wordpress Form Builder » Form not hiding after submission

  • Resolved tjdyo

    (@tjdyo)


    I have the After Form Submission section set to “Hide Form”, but after forms are submitted the popup is still staying on the screen.

    I also am having an issue with seeing the popup form on admin end, even with max submissions set to more than 1. I can’t even see the form to keep testing it on the same device on a separate browser or in TOR with a different IP address.

    Would be really nice to have a developer mode on to keep the popup form up until it has been fully tested.

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Contributor Samer Bazzi

    (@sbazzi)

    @tjdyo,

    one of our team members is looking in to this, we will be back with you soon.

    Thank You – Sam

    Plugin Author CRM Perks

    (@crmperks)

    we have fixed “hide_form” feature , it will hide form and show success message , it will not close popup , it will be available in next version

    you can test submission limit by using browser’s private window or different browser

    Thread Starter tjdyo

    (@tjdyo)

    So the popup won’t close on the hide_form feature? Maybe I’m reading that wrong….

    If so, that’s kind of pointless. I am specifically using the popup form to force users to enter in Name/Email in order to view webinars, so I have hidden the Close Popup Button (using CSS, since the feature in the app displays a broken image and is still clickable).

    If it does not auto close the popup upon completion, then what is the point of keeping a popup open?

    Plugin Contributor Samer Bazzi

    (@sbazzi)

    @tjdyo

    one of our team members will reply to this shortly.

    thank you – sam

    Plugin Author CRM Perks

    (@crmperks)

    that option is for hiding form and show success message like HubSpot popup https://i.imgur.com/t1Eu4uG.png

    close button is available because you have selected “No Button” https://i.imgur.com/X1zu687.png in settings

    Thread Starter tjdyo

    (@tjdyo)

    Yes, I have selected no button because I want people to fill out the information before being able to see a page.

    I am using the popup as a sort of “paywall” except that they are just entering their information, that way it can be transferred to MailChimp…

    Your answers leave a bad taste in my mouth. Why not make the plugin act the way that users would want, instead of telling them it doesn’t function that way. Why would we want it to say that it was completed and stay on the screen.

    Just have it say “form completed, thank you”, wait 1 second and then auto close the form. And to think, I was going to have my company purchase your suite to make all this easy for us. Now I’m seriously considering finding another set of plugins, as these issues are enough to make me leave.

    Plugin Author CRM Perks

    (@crmperks)

    i gave you example of hubspot in previous reply that Hubspot popup forms do not have this feature , means users do not need this feature
    but you requested this new feature, i personally like it
    you can do this by adding few lines of code in your functions.php , we can do this for you , you can get free help here https://www.crmperks.com/contact-us/

    Thread Starter tjdyo

    (@tjdyo)

    Thank you, I will write in right now.

    Plugin Contributor Samer Bazzi

    (@sbazzi)

    @tjdyo,

    look forward to it.

    thank you – sam

    Plugin Author CRM Perks

    (@crmperks)

    please use “Thank You Message Type” option in form settings

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Form not hiding after submission’ is closed to new replies.