• Resolved Pete

    (@capitaldigital)


    Hi, I have 3 forms which work fine, but I have added a fourth this morning, but cannot get it to appear on the site, either in preview or live. It appears fine in the preview from the Edit Form page.

    I used a blank form to create a checklist and used the CSS class ‘forminator-hidden’ to hide the ‘Send Message’ button.

    But rather than seeing the form, all that appears is an ‘Edit Form’ link that takes me back to the Forminator edit screen when I click on it.

    I’m using Siteground and have added the form URL to exclude the page from being cached.

    I’ve also checked the debug list and don’t see anything that looks like it’s related.

    I’ve read plenty of previous posts but none seem to have this exact issue.

    Thanks

Viewing 6 replies - 1 through 6 (of 6 total)
  • Hi @capitaldigital

    Sorry that’s happening. Could you please share an export of your form via a site like PasteBin or Google drive so people can take a closer look.

    Also try disabling all plugins to check if it’s a plugin conflict.
    Here’s the basic troubleshooting process for that – https://wpmudev.com/wp-content/uploads/2015/09/Support-Process-Support-Process.gif

    Thread Starter Pete

    (@capitaldigital)

    I think I’ve worked out what the issue is, but I have no idea whether it’s fixable.

    The other forms are on pages I created, but this one has been added to a course module within Memberpress Courses. When I added the shortcode for the new form to a test page that I created it worked fine.

    So, I need to get it to work in Memberpress. Any ideas?

    Thanks

    Plugin Support Zafer – WPMU DEV Support

    (@wpmudevsupport15)

    Hi @capitaldigital,

    I hope you are doing well today!

    Please try enabling “Load form using AJAX” and “Prevent page caching on form pages” options under Edit Form->Behavior->Rendering
    https://wpmudev.com/docs/wpmu-dev-plugins/forminator/#rendering

    If this does not help I suggest to perform full plugin/theme conflict test.

    Please make sure you have recent backups and perform this operation on your dev/staging site if possible.

    To learn more about a plugin conflict test, please see this guide below:
    https://wpmudev.com/docs/getting-started/getting-support/#conflict-test

    Check out this handy flowchart of the troubleshooting process detailed above.
    https://wpmudev.com/wp-content/uploads/2015/09/Support-Process-Support-Process.gif

    Kind regards,
    Zafer

    Thread Starter Pete

    (@capitaldigital)

    I’ve tried those suggestions, but still no joy.

    Plugin Support Adam – WPMU DEV Support

    (@wpmudev-support8)

    Hi @capitaldigital

    Thanks for response!

    It seems that Memberpress/MemberPress Courses aren’t free and I don’t have any access to them so I cannot test Forminator forms with them.

    It’s possible that there is some sort of a conflict there but to first: are you sure that shortcodes (or – all shortcodes) are actually even allowed there and processed?

    It’s not uncommon that at some locations plugins do not allow use of shortcodes or are filtering them allowing only certain ones (like their own). Can you confirm that shortcodes work there in general?

    Have you tried to ask Memberpress support for additional assistance? they might be able to shed some light on this too.

    Kind regards,
    Adam

    Thread Starter Pete

    (@capitaldigital)

    If anyone else has this issue, go to WP-Admin -> MemberPress -> Settings -> Courses and change the option, “WP Footer Hook” to “Enabled”.

    After doing this, the form appeared correctly, but it also messed with other plugins and caused all the GDPR cookie info to appear at the bottom of the page which required some additional CSS to correct. I guess it depends on your theme, plugins etc, but this is what worked for me

    .mpcs-classroom #cookie-law-info-bar,
    .mpcs-classroom footer div[class*='cli-modal'],
    .mpcs-classroom .hestia-scroll-to-top,
    .mpcs-classroom footer img[title*='MonsterInsights'],
    .mpcs-classroom .forminator-edit-module {
    	display: none !important;
    }
Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Form not appearing in preview or live’ is closed to new replies.