Support » Plugin: Ninja Forms - The Easy and Powerful Forms Builder » Form no longer displaying bug

  • Resolved bootupword

    (@bootupword)


    I am running ninja 3.2.14 and the form will work for a while and then stop displaying in chrome, internet explorer etc.

    To remedy, I need to duplicate form and change and publish new form shortcode then everything is fine for a while and then form stops displaying again.

    This was just an issue with IE then when using wp ninja version 3.2.12 and was resolved in 3.2.13 but now appears to be another bug since the security version update of 3.2.14.

    Why does the form start working for a while after I duplicate existing form and publish new shortcode ID of the duplicated form?

Viewing 15 replies - 1 through 15 (of 18 total)
  • Plugin Contributor Justin McElhaney

    (@jmcelhaney)

    We have not had other users report this issue. Can you submit a ticket to https://ninjaforms.com/contact so we can help you further?

    Problem with the form not displaying only began for us at version 3.2.12 and only affected IE browsers.

    Version 3.2.13 resolved IE browser display bug.

    Version 3.2.14 security update was applied and now the form will work for a while an then users report that the form is not displaying and it affects all browsers.

    Any ideas of what I might try to debug when using an existing setup? Tried disabling all plugins (5). Duplicating the form and using the new form ID temporarily fixes the form display issue on all browsers… not sure why?

    Plugin Contributor Justin McElhaney

    (@jmcelhaney)

    Can you submit a ticket to https://ninjaforms.com/contact so we can help you further?

    Is anyone else having a problem with their forms no longer displaying.? My clients website displays two forms on the home page but the main form has stopped displaying, possibly since the update, on older ipads and some PC’s. I rebuilt the form and it displayed fine… for a few days then is no longer displaying. Just hoping someone has come across the same issue and fixed it ? I’ve deactivated plugins and switched to default theme btw 🙂 Ninja Support say “What we run into is if either Apple or Microsoft aren’t supporting those versions of their operating system that you’re encountering these issues on we aren’t able to troubleshoot unsupported versions of their own browsers and support systems” Any ideas ? Jeanette

    http://www.majorcabdriver.com/

    Jeanette,

    In the forms, under Restrictions options, check and see if you had enabled “Limit Submissions”. This was causing my form to stop displaying after the number of submissions entered. I misunderstood this option and have since disabled it and now the form appears to be working normal.

    Thank you 🙂 I checked that and restrictions was not enabled.
    It’s a mystery why it is not displaying on certain devices but OK on iphone and Mac but not on some older ipads.

    When I recreated it, it worked for a few days.

    I had a similar experience with forms not displaying on IE 11 browsers. Then ninja released update a few weeks back and that resolved the issue with forms not displaying on IE browsers.

    I realize its impossible to support older devices/browsers but noting that fact, if known, would be extremely helpful.

    Perhaps you could try testing older version of ninja and form with the devices having issues.

    So Ninja keep saying it’s out of date browsers etc.

    I have a second website with the same issue. I uninstalled Ninja and reinstalled and recreated (a rather large form grrr 🙂 and it now displays on the older ipad. I’m hoping it stays working.

    Doesn’t this prove Ninja has a bug ?

    I feel fobbed off from them so would be nervous about upgrading now…

    On a side note, does exporting/importing your form not work vs recreating the form?

    Not sure if it proves a bug. Assuming the browsers your testing are still being supported and up to date, does Ninja support the older browser versions would be my next question.

    Just to update this in case anyone else had a problem. Ninja updates looks like it fixed the problem – they included something about long forms not displaying and now my problem has disappeared 🙂 so I guess it was a bug after all.

    Same bug in my case, are you sure it’s fixed ? I have the latest, but form not display in Ipad.

    How to debug ?

    How did you guys do this, I’m having the same trouble. I always have to create a new form because suddenly after the last few updates, my forms suddenly stops displaying. thanks!

    @expressionssg did you confirm you don’t have the limit submissions field set?
    It sounds like recreating the form is resetting that field allowing a further X number of submissions before the form stops displaying.
    Or, try setting it to enabled and a number, saving the settings. Then clearing the setting and saving again to see if that clears it.

    Hi guys. Same problem here. I have more websites and on one, the form stopped working. It´s not a problem with limit submissions, I checked. Since it´s working on all languaage mutations of website, exept for this one, I have no idea what´s the problem. I created a new form and loaded it to website, but no, doesnt work 🙁

    @shinerweb I already checked the submissios field yesterday upon reading this. But still no good, and I just tried today the Limit Submission as you mentioned above, and still no good.

Viewing 15 replies - 1 through 15 (of 18 total)
  • The topic ‘Form no longer displaying bug’ is closed to new replies.