Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Support Patrick – WPMU DEV Support

    (@wpmudevsupport12)

    Hi @yarintosh

    Sorry to hear you are having this problem.

    It sounds like a cache issue.

    Could you please go to the Forminator > Form > Behaviour and select the option to Load from Ajax?

    https://wpmudev.com/docs/wpmu-dev-plugins/forminator/#behavior-forms

    Once done, check if the issue is gone.

    Let us know the result you got.
    Best Regards
    Patrick Freitas

    Thread Starter yarintosh

    (@yarintosh)

    @wpmudevsupport12 Changed it, still not working

    • This reply was modified 1 year, 8 months ago by yarintosh.
    Plugin Support Pawel – WPMU DEV Support

    (@wpmudev-support9)

    Hi @yarintosh,

    I was able to make a test submission recently. I do see a JS error in console using Chrome developer tools. This points to a cache file. Are you currently using any optimization or caching plugins?

    If so, please purge all cache or temporarily deactivate this option in order to verify if this is what may be affecting your form submission.

    Best,
    Jonathan S

    Thread Starter yarintosh

    (@yarintosh)

    @wpmudev-support9 I’ve done that yesterday after applying the “Load from Ajax”.
    After purging it worked but the question is will it still work in a few days? Usually after few days (I guess because of the caching problem) it stops working.

    Plugin Support Patrick – WPMU DEV Support

    (@wpmudevsupport12)

    Hi @yarintosh

    Sorry for the delay here.

    In case the issue return after some time, it means the caching plugin is causing some issues.

    For example this JavaScript problem:
    https://monosnap.com/file/LatrCKEGOVIgi9Zfu0eoMVEtPNnV1T

    I couldn’t find from which plugin it is returning, but it uses a JavaScript library https://imagesloaded.desandro.com/ which returns the error.

    It is a good idea to exclude some files from optimization for example jQuery-core and jQuery-migrate or other files that return errors like the screenshot.

    As the Forminator depends on jQuery if a code breaks the jQuery from running on the page can cause a problem on the form and sometimes it isn’t even the Form script but another plugin script.

    Best Regards
    Patrick Freitas

    Plugin Support Patrick – WPMU DEV Support

    (@wpmudevsupport12)

    Hi @yarintosh

    I hope you are doing well and safe!

    We haven’t heard from you in a while, I’ll mark this thread as resolved.

    Feel free to let us know if you have any additional question or problem.

    Best Regards
    Patrick Freitas

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Form is stuck at sending’ is closed to new replies.