Support » Plugin: Contact Form 7 » Form is not working from this morning

  • Resolved Armando

    (@kmzerowebmarketing)


    Dear,
    CF7 contact form on the web site doesn’t send mail anymore and show the following message:
    “There was an error trying to send your message. Please try again later.”
    Usually is working fine, we do not make any change on the configuration.
    Just update WP and all the plugins few days ago.

    Any ideas?

    The page I need help with: [log in to see the link]

Viewing 3 replies - 1 through 3 (of 3 total)
  • I had a very similar issue.

    You have this console error:

    Uncaught ReferenceError: grecaptcha is not defined
        at (index):380

    The reCaptcha script is being deferred

    <script defer="" src="https://www.google.com/recaptcha/api.js?render=6Lco3eAUAAAAAIzgY0WSHB1I6uHF09qoc9WspXpQ#038;siteground-async=1&ver=3.0"></script>

    And another is being loaded asynchronously:

    <script type="text/javascript" async="" src="https://www.gstatic.com/recaptcha/releases/zItNOfzbrqVGbb4QFYpPpcrw/recaptcha__en.js"></script>

    Not sure what the asynchronously loading script is but when I stopped deferring that first script it started working for me.

    Hope that helps 🙂

    • This reply was modified 2 years, 3 months ago by Joshaw.
    Thread Starter Armando

    (@kmzerowebmarketing)

    Many thanks Joshaw!
    I just reconfigure the Google ReCapcha Keys and form start to work.

    Thanks

    @kmzerowebmarketing thank you for letting me know, I guess that means the scripts CAN actually be deferred… It must be the order of my scripts or something.

    Appreciate you letting me know what worked for you!

    Thanks,

    Jo

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Form is not working from this morning’ is closed to new replies.