Support » Plugin: Contact Form 7 » Form is not sending emails

  • Resolved sunsetla

    (@sunsetla)


    Hi,

    I can’t get my forms to send an email once submitted. I’m not getting an error when I click submit. I’ve since added Flamingo plugin and I can see the submitted form in there. I’ve tried disabling all of my plugins as well as changing my theme.

    Any help would be much appreciated!

    The page I need help with: [log in to see the link]

Viewing 3 replies - 1 through 3 (of 3 total)
  • I recently had to deal with a similar issue, but there was a warnng message to contact the administrator. Upon testing, I found that removing the form’s code for recaptcha cleared up the problem. Now looking for a way to add a captcha or other spam preventative that will replace it.

    Thread Starter sunsetla

    (@sunsetla)

    I resolved the issue. It had to do with Godaddy’s MX Entry settings.

    1. You need to have a cPanel enabled hosting account
    2. Log into CPanel and go to the bottom to the email section and click MX Entry.
    3. Click the button that says ‘remote’, it will most likely be on ‘local’, the default
    4. Click Change, and wait 10 to 15 minutes. IT IS NOT INSTANT!
    5. Try the form send again after 15 minutes

    https://www.godaddy.com/community/Managing-WordPress/Contact-Form-7-stopped-sending-emails/td-p/18431

    Set to “local” and tested after 30 minutes with no luck.
    After that i set to “remote” and tested after 30 minutes with no luck.

    Yet is “remote” and in MX Records default is “@ (Priority: 0)”

    • This reply was modified 3 years, 2 months ago by S o f t f u l l y. Reason: More info
Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Form is not sending emails’ is closed to new replies.