Support » Plugin: Page Builder Gutenberg Blocks – CoBlocks » Form has no submit button

  • Resolved Hugh Lashbrooke

    (@hlashbrooke)


    I have a contact form using the Form block on my site and the submit button doesn’t show up on the frontend at all: https://www.southerncrosschurch.org/contact/ – I was using a Jetpack contact form here, which worked just fine (so I know email sending works), but with the CoBlocks form, there is not submit button on the frontend, even though it shows up in the block when editing the page.

    I tried it with/without ReCAPTCHA and that didn’t make a difference.

    I see this in the page source for the submit button:

    <button type="submit" class="wp-block-button__link wp-block-button__link has-background has-text-color" style="">Array</button>

    It looks like it’s interpeting the string in the button as an array and therefore not showing anything.

    The page I need help with: [log in to see the link]

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Anthony Ledesma

    (@paranoia1906)

    Hi @hlashbrooke,

    Sorry for the delay in getting back to you. I have had trouble replicating this one. It looks like you are using the Jubilee theme for this site. Are you able to replicate this on any other theme? Perhaps you could make a Gif or video of you replicating this bug? I’ve tried setting styles, setting the button text, and changing themes but I am consistently able to render the submit button. I would appreciate any further time you could take to explain this issue.

    Best,

    Anthony

    Plugin Author Anthony Ledesma

    (@paranoia1906)

    Hi @hlashbrooke,

    I was able to track down this bug while testing compatibility with WordPress 5.4. CoBlocks has now been updated to V1.23.0 which contains a fix for the issue you reported. Thank you very much for taking the time to create this bug report and helping to make CoBlocks better.

    Please test out the latest version and let me know if you are still experiencing issues.

    Best regards,

    Anthony

    Thread Starter Hugh Lashbrooke

    (@hlashbrooke)

    Oh great – thanks!

    I had switched back to a Jetpack form, but I much prefer the UI and look of the CoBlocks one, so I’ll switch back to that now!

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Form has no submit button’ is closed to new replies.