Support » Plugin: Greenhouse Job Board » Form Fields not Showing

  • We are looking to show location on our apply forms. We have checked all our job listings and have that as a required field but the only fields showing on the inline form are the standard FN, LN, Email, Phone, Resume, Cover Letter, and a few custom questions. If I switch the settings in the plugin to display an iFrame form then Location shows on the apply form.

    Additionally, in the plugin settings. How do you utilize the “Form Fields” option where the instructions state “Select the form fields you would like to display on your apply forms by default, List either the form labels or names from greenhouse. Note that this is only used when using inline forms (and not iframes)”?

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author brownbagmarketing

    (@brownbagmarketing)

    So there’s a multiple choice of locations to apply to in the application? Like a position could be in multiple locations and in the application you want the applicant to select the location(s) in which they want to be considered? The issue may be that the plugin so far doesn’t support multi-select custom fields (it’s the only field type that the greenhouse API was having issues receiving data with). Let us know if that’s the field type you are using.

    As for your other question: the Form Fields options is for filtering the fields that display in the form. By default it just displays everything, so unless you want to restrict the fields that are displayed you can leave that part blank. It accepts the field name (like first_name) or the form title (First Name), pipe delimited (first_name|last_name|…), we will update the docs to detail all of this.

    Thank you for the reply. The location is actually a text field and a default field from Greenhouse. Within GH there is a location field where applicants can list their location so that those hiring know if the applicant is local or may need to relocate. Example: If I am in San Francisco, CA I would enter that location in the text field. I have inspected the field value and tried this in the filter option as well as the field label name and neither are working. If I enter this value the form returns on the front-end blank. If I enter first_name|location this too renders a blank form. I am just trying to determine how to get this default field from GH onto my form.

    Plugin Author brownbagmarketing

    (@brownbagmarketing)

    Ah, if it’s just a text field I don’t see any reason why it shouldn’t be showing up. Are you clearing the cache once you add that field? That may explain why it shows up on iframe but not on the inline forms.

    The field in question is the job_application_location or job_application[location] depending on which value I should be looking at. The field does appear to be connected to location assistance. Any suggestions on how I can get this field to show? I have confirmed on the GH side it is selected to show and as mentioned – am able to see if it I choose the iFrame form type over Inline.

    Plugin Author brownbagmarketing

    (@brownbagmarketing)

    After running a few tests we’re still not able to reproduce this result. There are many many settings within Greenhouse, but I’m not certain which ones would keep a field from being sent in the api response. Do you have a dev link or anything? You can email it to us if you prefer (wordpress at our domain dot com)

    I do have a staging environment and we can disable all themes and plugins (minus yours) to debug down if needed. I will send an email.

    Plugin Contributor Evan Mullins

    (@circlecube)

    Did you send that email? Haven’t seen it yet. wordpress at brownbagmarketing.com

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Form Fields not Showing’ is closed to new replies.