Support » Plugin: Booking Calendar » Form field translations not working

  • Resolved Rob de Cleen

    (@rdc2701)


    Hi,

    Thanks for this great plugin. I have an issue with the translation of the form fields in the free version with Enfold theme. Adding [lang=locale_LOCALE] after the English form fields used to work fine, but it doesn’t anymore (probably since the latest version 8.8.2). Funny thing is: it still works well on the SEND button field. I use PHP 7.4.21 and Falang translation plugin. Used to work fine. With or without W3TotalCache result is the same.
    Also the calendar does not switch to the locale language anymore, so days and months are always in English now.
    Can you help? Thanks in advance!

    Rob

    • This topic was modified 3 months, 2 weeks ago by Rob de Cleen. Reason: typo
Viewing 15 replies - 1 through 15 (of 25 total)
  • Plugin Author wpdevelop

    (@wpdevelop)

    Hello.
    Please be sure that you have correctly defined the locale for your website. Please recheck it at the WordPress > Settings General page. Or in your translation plugin, if you use someone.

    Otherwise send the link to your page with booking form, where you are having the issue.
    Thank you.

    Thread Starter Rob de Cleen

    (@rdc2701)

    Hi,
    Thanks for your reaction. Site lanuage is set to English US, secondary language is set to nl_NL in Falang.

    EN page shows in source:
    <link
    rel=alternate href=https://mforamsterdam.com/info/booking-calendar/ hreflang=en-US>
    <link
    rel=alternate href=https://mforamsterdam.com/nl/info/boekingskalender/ hreflang=nl-NL>

    NL page shows in source:
    <link
    rel=alternate href=https://mforamsterdam.com/info/booking-calendar/ hreflang=en-US>
    <link
    rel=alternate href=https://mforamsterdam.com/nl/info/boekingskalender/ hreflang=nl-NL>

    EN:
    https://mforamsterdam.com/info/booking-calendar/
    NL:
    https://mforamsterdam.com/nl/info/boekingskalender/

    Thanks for your help

    Plugin Author wpdevelop

    (@wpdevelop)

    Hello.

    I have checked your page and in Dutch language the locale at your website is showing as “en_US”.

    1) Please recheck for any cache plugins, like “WP Super Cache”, “WP Fastest Cache” or “W3 Total Cache”. If you are using someone, please deactivate it or add the exception to the page with booking form for do not cache this page(s).

    2) Otherwise probably it’s because of conflict with some other plugin or actual theme.
    Please try to deactivate one by one all your active plugins at the WordPress > Plugins menu and make testing after each plugin deactivation.
    If it does not help, please deactivate all your plugins and active the default WordPress theme. And then retest it again.
    We just need to find the reason for this issue.

    Kind Regards.

    Thread Starter Rob de Cleen

    (@rdc2701)

    Hi,

    Thanks for the tips, I will try to find the reason by following this on a staging site.
    I use W3 Total Cache, but the booking calendar pages are already excepted from being cached.
    Also disabling W3 Total Cache does not make a difference.
    If I find a reason I will update here.

    Thanks so far!
    Regards,
    Rob

    Plugin Author wpdevelop

    (@wpdevelop)

    Hello.
    For me, it seems like the page was cached, still.
    Kind Regards.

    Thread Starter Rob de Cleen

    (@rdc2701)

    Hi,
    Just tested some more, here’s the results:

    == STAGING site: ==

    WITHOUT W3 Total Cache deactivated:
    EN page source: <html lang=”en-US”
    NL page source: <html lang=”nl”
    Title of send button: Send[lang=nl_NL]Verzenden > WORKS
    Other field titles (same system) > not working
    Calendar days/months stay en_US even in NL

    WITH W3 Total Cache activated:
    EN page source: <html lang=”en-US”
    NL page source: <html lang=”nl”
    Title of send button: Send[lang=nl_NL]Verzenden > WORKS
    Other field titles (same system) > not working
    Calendar days/months stay en_US even in NL

    Deactivating plugins > no difference (tested with deactivated W3 Total Cache)

    == LIVE site: ==
    same results, except Title of send button: Send[lang=nl_NL]Verzenden > not working
    Other field titles (same system) > not working
    Calendar days/months stay en_US even in NL

    I cannot test without the Enfold theme, then nothing works.
    I’m out of ideas now šŸ™‚

    Thanks again for your attention.
    Rob

    Plugin Author wpdevelop

    (@wpdevelop)

    What translation plugin do you use ?
    You need to check your active locale near “wpbc_active_locale”
    Kind Regards.

    Plugin Author wpdevelop

    (@wpdevelop)

    Try to change language at the WordPress > Settings General page and test it.
    Kind Regards.

    Thread Starter Rob de Cleen

    (@rdc2701)

    I use Falang for WordPress:
    https://wordpress.org/plugins/falang/

    Switching to NL in WP Settings makes NL work just fine, except then the en_US language also becomes NL for the field titles, and the days/months become NL also for both languages.

    • This reply was modified 3 months, 2 weeks ago by Rob de Cleen. Reason: typo
    Thread Starter Rob de Cleen

    (@rdc2701)

    Sorry, forgot this part as answer to your post

    Indeed, both EN and NL have: “wpbc_active_locale”:”en_US” on the booking calendar page in the page source…

    I will contact the developer of Falang to see if he can find a reason for that.
    Thanks for your help!

    Kind regards,
    Rob

    Plugin Author wpdevelop

    (@wpdevelop)

    Currently the “Falang ” plugin is not officially supported in the plugin.
    Booking Calendar support WPML and “qTranslate” plugins, Please check more here https://wpbookingcalendar.com/faq/several-languages/

    In your “Falang” plugin, please try to set the nl_NL locale instead of nl. Then test it, or therwise try those other translation plugins.
    Kind Regards.

    Thread Starter Rob de Cleen

    (@rdc2701)

    Falang is WPML compatible, and the locale in Falang is already set to “nl_NL”, with SEF language code “nl”.
    Thanks for your help.

    Thread Starter Rob de Cleen

    (@rdc2701)

    Hi,

    Just a follow-up: I just did one more test on a staging site.
    Form field titles translations worked fine with the same exact setup and Booking Calendar 8.8.1. After upgrade to Booking Calendar 8.8.2 the issue reported above shows. This menas that the issue is not with Falang translation plugin.

    What was changed between version 8.8.1 and 8.8.2 of Booking Calendar that could have caused this?

    Kind regards,
    Rob

    • This reply was modified 3 months, 2 weeks ago by Rob de Cleen. Reason: typo
    Plugin Author wpdevelop

    (@wpdevelop)

    Hello.
    We was not changed anything relative to the translation or form fields configuration.
    It’s possible that at the original and staging site is different order of setting locale of your website by the translation plugin. I suggest that at the original website, it’s defined later then at the staging. You can try to update plugin to the update 8.8.2 and then retest it.
    Also do you have the same issue at the admin panel at the Booking > Add booking page ?
    Kind Regards.

    Thread Starter Rob de Cleen

    (@rdc2701)

    Hi,

    I just downgraded Booking Calendar to 8.8.1 on the live website without changing anything else. As you can see, the NL translation on the form fields works fine now.
    EN: https://mforamsterdam.com/info/booking-calendar/
    NL: https://mforamsterdam.com/nl/info/boekingskalender/
    On the NL page there is now “wpbc_active_locale”:”nl_NL” in the page source.
    Days/months change to NL just fine.

    The issue is only with the frontend, the admin backend of the site (and thus Booking Calender admin is always kept to en_US.

    When I login as a user with language set to NL for backend administration: everything is fine days/months and all admin pages in Booking Calendar are NL, as they should be.

    So there definitely is something happening when upgrading to BC 8.8.2 which changes the frontend form field titles behaviour.

    Kind regards

    • This reply was modified 3 months, 2 weeks ago by Rob de Cleen. Reason: typos, again :-)
Viewing 15 replies - 1 through 15 (of 25 total)
  • You must be logged in to reply to this topic.